summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-11 00:13:10 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-11 00:25:13 +0100
commit780818b4b055f8c41d253e71cd9641322776e7a4 (patch)
treed77b9834f3df0b9011f8b049ddc4796ad659c410 /dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild
parentprofiles: Update the ICD-loader mask (commit a41cdae97af) (diff)
downloadgentoo-780818b4b055f8c41d253e71cd9641322776e7a4.tar.gz
gentoo-780818b4b055f8c41d253e71cd9641322776e7a4.tar.bz2
gentoo-780818b4b055f8c41d253e71cd9641322776e7a4.zip
dev-libs/ocl-icd: use dev-util/opencl-headers instead of bundled ones
Builds just fine against these, which is not surprising given both sets are official Khronos Group OpenCL 2.2 headers - the only difference being the bundled ones are legacy and the separately packaged ones are unified. Furthermore, without having to worry about file collisions in /usr/include/CL, it will become possible for packages depending on unified headers (e.g. dev-libs/intel-neo, which too uses a bundled copy for now) to use dev-util/opencl-headers regardless of which ICD loader provides the library. Last but not least, one bundling less to worry about! Note that this change makes USE=khronos-headers redundant, that said we keep it in IUSE - at least for now anyway - so that ebuilds explicitly requesting this USE flag needn't be modified. No revbump because the first commit introducing -r3 has at the time of me writing this not had been pushed to Gentoo servers yet. Committed directly due to prolonged absence of the maintainer. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild')
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild b/dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild
index 783021a439e5..980cac2e7506 100644
--- a/dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild
+++ b/dev-libs/ocl-icd/ocl-icd-2.2.12-r3.ebuild
@@ -13,10 +13,16 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Does nothing now but by keeping it here we avoid having to have virtual/opencl
+# handle ebuilds both with and without this flag.
IUSE="+khronos-headers"
BDEPEND="${RUBY_DEPS}"
-RDEPEND="!app-eselect/eselect-opencl
+DEPEND="dev-util/opencl-headers"
+# nvidia-drivers block is hopefully temporary, until it has ceased
+# to depend on eselect-opencl
+RDEPEND="${DEPEND}
+ !app-eselect/eselect-opencl
!dev-libs/opencl-icd-loader
!x11-drivers/nvidia-drivers"
@@ -30,7 +36,9 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf --enable-pthread-once
+ # dev-util/opencl-headers ARE official Khronos Group headers, what this option
+ # does is disable the use of the bundled ones
+ ECONF_SOURCE="${S}" econf --enable-pthread-once --disable-official-khronos-headers
}
multilib_src_install() {
@@ -38,10 +46,4 @@ multilib_src_install() {
# Drop .la files
find "${ED}" -name '*.la' -delete || die
-
- # Install vendor headers
- if use khronos-headers; then
- insinto /usr/include
- doins -r "${S}/khronos-headers/CL"
- fi
}