summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ocl-icd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ocl-icd')
-rw-r--r--dev-libs/ocl-icd/Manifest2
-rw-r--r--dev-libs/ocl-icd/metadata.xml8
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.1.3.ebuild36
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.2.3.ebuild35
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/ocl-icd/Manifest b/dev-libs/ocl-icd/Manifest
new file mode 100644
index 000000000000..42e089fc5a91
--- /dev/null
+++ b/dev-libs/ocl-icd/Manifest
@@ -0,0 +1,2 @@
+DIST ocl-icd-2.1.3.tar.gz 419083 SHA256 8338c6ae5cb7a9b34dfe79922f5e32c4f78c535a2217321dae842f72e0a2b175 SHA512 5d0704bed8a664950131c985fc32ffe5e078874945642417122df79c66bad804307192db49a561330268664ceb59756b268cf52201b809398efe58c85f823ad3 WHIRLPOOL f2757e00dcd9d484b1536ebb6b776bf5b54cd3e13cfa1b56fc95ef1e71f3db36bdb4ff996b2ddfb18d63082ebfdf743b9aeb41ed76910020724cfde7839e741b
+DIST ocl-icd-2.2.3.tar.gz 446966 SHA256 93a5ac3b23fb10731cc9e6406a58f7a21825562877787ed08c3a41f08b504d0c SHA512 da890da32cd61e42f610df472ac651d47edb1b014d98c25a778551fe6973bdb47753417b2eeab220a07f2862468845e3ac31a2e9631eac5eed05153f09da2cb9 WHIRLPOOL 1025d9b10d0140777d50abef5049df033b5a3f405807997eef3c3d88c7d4c1bd568316a20a40f936eb253da5b473aedbc764702bf5145c6c4203d85b6b420239
diff --git a/dev-libs/ocl-icd/metadata.xml b/dev-libs/ocl-icd/metadata.xml
new file mode 100644
index 000000000000..6719fcd2bb35
--- /dev/null
+++ b/dev-libs/ocl-icd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/ocl-icd/ocl-icd-2.1.3.ebuild b/dev-libs/ocl-icd/ocl-icd-2.1.3.ebuild
new file mode 100644
index 000000000000..ceecc6091b40
--- /dev/null
+++ b/dev-libs/ocl-icd/ocl-icd-2.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
+HOMEPAGE="http://forge.imag.fr/projects/ocl-icd/"
+SRC_URI="https://forge.imag.fr/frs/download.php/524/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="dev-lang/ruby"
+RDEPEND="app-eselect/eselect-opencl"
+
+src_prepare() {
+ echo "/usr/$(get_libdir)/OpenCL/vendors/ocl-icd/libOpenCL.so" > ocl-icd.icd
+}
+
+src_install() {
+ insinto /etc/OpenCL/vendors/
+ doins ocl-icd.icd
+
+ emake DESTDIR="${D}" install
+
+ OCL_DIR="${D}"/usr/"$(get_libdir)"/OpenCL/vendors/ocl-icd/
+ mkdir -p ${OCL_DIR} || die "mkdir failed"
+
+ mv "${D}/usr/$(get_libdir)"/libOpenCL* "${OCL_DIR}"
+}
diff --git a/dev-libs/ocl-icd/ocl-icd-2.2.3.ebuild b/dev-libs/ocl-icd/ocl-icd-2.2.3.ebuild
new file mode 100644
index 000000000000..1cd0749aaf81
--- /dev/null
+++ b/dev-libs/ocl-icd/ocl-icd-2.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
+HOMEPAGE="http://forge.imag.fr/projects/ocl-icd/"
+SRC_URI="https://forge.imag.fr/frs/download.php/598/${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="dev-lang/ruby"
+RDEPEND="app-eselect/eselect-opencl"
+
+src_prepare() {
+ echo "/usr/$(get_libdir)/OpenCL/vendors/ocl-icd/libOpenCL.so" > ocl-icd.icd
+}
+
+src_install() {
+ insinto /etc/OpenCL/vendors/
+ doins ocl-icd.icd
+
+ emake DESTDIR="${D}" install
+
+ OCL_DIR="${D}"/usr/"$(get_libdir)"/OpenCL/vendors/ocl-icd/
+ mkdir -p ${OCL_DIR} || die "mkdir failed"
+
+ mv "${D}/usr/$(get_libdir)"/libOpenCL* "${OCL_DIR}"
+}