summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-12-06 20:08:36 +0000
committerMike Gilbert <floppym@gentoo.org>2019-12-06 15:24:38 -0500
commitd903684ed2f3ba757cb13cb98386608c4f839188 (patch)
tree91e582ec88093df9f942f69a4643c427977cf5d5 /dev-libs/oniguruma/oniguruma-6.9.4.ebuild
parentdev-db/sqlite: Stabilize 3.30.1 on amd64/x86. (diff)
downloadgentoo-d903684ed2f3ba757cb13cb98386608c4f839188.tar.gz
gentoo-d903684ed2f3ba757cb13cb98386608c4f839188.tar.bz2
gentoo-d903684ed2f3ba757cb13cb98386608c4f839188.zip
dev-libs/oniguruma: Minor fixes.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma/oniguruma-6.9.4.ebuild')
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.4.ebuild28
1 files changed, 25 insertions, 3 deletions
diff --git a/dev-libs/oniguruma/oniguruma-6.9.4.ebuild b/dev-libs/oniguruma/oniguruma-6.9.4.ebuild
index 89ceadf44729..d5ee1bbf47de 100644
--- a/dev-libs/oniguruma/oniguruma-6.9.4.ebuild
+++ b/dev-libs/oniguruma/oniguruma-6.9.4.ebuild
@@ -5,21 +5,43 @@ EAPI="7"
inherit multilib-minimal
-MY_P="onig-${PV}"
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+fi
DESCRIPTION="Regular expression library for different character encodings"
HOMEPAGE="https://github.com/kkos/oniguruma"
-SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+fi
LICENSE="BSD-2"
SLOT="0/5"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="crnl-as-line-terminator static-libs"
-S="${WORKDIR}/${MY_P}"
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/onig-${PV}"
+fi
DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+src_prepare() {
+ # https://github.com/kkos/oniguruma/issues/167
+ # https://github.com/kkos/oniguruma/commit/603f4db48efb49307b7515500496e9e7a92fb779
+ sed -e "/^#define MATCH_AT_ERROR_RETURN(err_code)/s/best_len = err_code; goto match_at_end/do {&;} while(0)/" -i src/regexec.c || die
+
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable crnl-as-line-terminator) \