summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-05 03:21:10 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-05 03:21:38 +0100
commit1474e69a446cd9d14be44a414c8379b40614d895 (patch)
tree9ccf54afbcf67fb13735bbcbea3e9e2831f61c8e /dev-libs/oniguruma
parentnet-firewall/nftables: Depend on >=net-libs/libnftnl-1.1.5 (diff)
downloadgentoo-1474e69a446cd9d14be44a414c8379b40614d895.tar.gz
gentoo-1474e69a446cd9d14be44a414c8379b40614d895.tar.bz2
gentoo-1474e69a446cd9d14be44a414c8379b40614d895.zip
dev-libs/oniguruma: bump to v6.9.4
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/Manifest1
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/Manifest b/dev-libs/oniguruma/Manifest
index 5f7bff0c53a2..ce7f6724dd5c 100644
--- a/dev-libs/oniguruma/Manifest
+++ b/dev-libs/oniguruma/Manifest
@@ -1 +1,2 @@
DIST onig-6.9.3.tar.gz 902349 BLAKE2B 4b20290a2d72b638b13a2e2edc89e072a8d17f89f6a273b58d0e408d01726ace948dd390bb2f4c478b87d01bed9fa344a4933060736a40981219301529957aaa SHA512 6b038879cb9cbe8cc756159eb53125e1d4dc7365ca434d07b99a59f3602987e573da120506bbd88d0f51dcdde5866bfa48d45803f8869503726c4d9a47d62861
+DIST onig-6.9.4.tar.gz 908702 BLAKE2B e6e9939f284569408ba01b8551960bc939bbfdca425f8470499f5bb83ead7b6b09898f6f6a09d5d8c26d74d5416f6e5e9e2f00fbe7aa9eb820edb8aa4a3050cc SHA512 ed8f42f6893966c0ee3c168b4fdbcb04b2286ad69ecab43a754c1dbc8fc4656e01319991d776d7144b6a3f90d050781b321432278d83c74c9565c2743851c85b
diff --git a/dev-libs/oniguruma/oniguruma-6.9.4.ebuild b/dev-libs/oniguruma/oniguruma-6.9.4.ebuild
new file mode 100644
index 000000000000..43db68779b27
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="onig-${PV}"
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="crnl-as-line-terminator static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name "*.la" -type f -delete || die
+}