summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-08-28 12:08:03 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-08-28 12:08:38 -0700
commitafff3103d8b81f06058e0b0028bd19f8decca724 (patch)
tree05bcd9a8fb007b48b85283e2dd932dd6499110b5 /dev-libs/openssl/openssl-0.9.8z_p8.ebuild
parentdev-libs/xapian: use ${ED} instead of ${D} to fix prefix (diff)
downloadgentoo-afff3103d8b81f06058e0b0028bd19f8decca724.tar.gz
gentoo-afff3103d8b81f06058e0b0028bd19f8decca724.tar.bz2
gentoo-afff3103d8b81f06058e0b0028bd19f8decca724.zip
dev-libs/openssl: bug 629224: fix global tr.
Package-Manager: Portage-2.3.6, Repoman-2.3.3 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-libs/openssl/openssl-0.9.8z_p8.ebuild')
-rw-r--r--dev-libs/openssl/openssl-0.9.8z_p8.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/openssl/openssl-0.9.8z_p8.ebuild b/dev-libs/openssl/openssl-0.9.8z_p8.ebuild
index cc1b39afb2cb..f6a3c0025f10 100644
--- a/dev-libs/openssl/openssl-0.9.8z_p8.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8z_p8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# this ebuild is only for the libcrypto.so.0.9.8 and libssl.so.0.9.8 SONAME for ABI compat
@@ -7,7 +7,8 @@ EAPI="5"
inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
-PLEVEL=$(echo "${PV##*_p}" | tr '[1-9]' '[a-i]')
+#PLEVEL=$(printf "\\$(printf '%03o' $((${PV##*_p} + 96)))")
+PLEVEL='h' # _p8 -> tr '[1-9]' '[a-i]' -> 'h'
MY_PV=${PV/_p*/${PLEVEL}}
MY_P=${PN}-${MY_PV}
S="${WORKDIR}/${MY_P}"