summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ossp-uuid/ossp-uuid-1.6.2-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ossp-uuid/ossp-uuid-1.6.2-r4.ebuild')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2-r4.ebuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r4.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r4.ebuild
new file mode 100644
index 000000000000..097104758186
--- /dev/null
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="uuid-${PV}"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_S="${WORKDIR}/${MY_P}/php"
+PHP_EXT_OPTIONAL_USE="php"
+USE_PHP="php5-5 php5-4"
+
+GENTOO_DEPEND_ON_PERL="no"
+
+inherit eutils multilib perl-module php-ext-source-r2
+
+DESCRIPTION="An ISO-C:1999 API and corresponding CLI for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID"
+HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/uuid/${MY_P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="+cxx perl php static-libs"
+
+DEPEND="perl? ( dev-lang/perl:= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+
+ epatch \
+ "${FILESDIR}/${P}-gentoo-r1.patch" \
+ "${FILESDIR}/${P}-gentoo-perl.patch" \
+ "${FILESDIR}/${P}-hwaddr.patch" \
+ "${FILESDIR}/${P}-manfix.patch" \
+ "${FILESDIR}/${P}-uuid-preserve-m-option-status-in-v-option-handling.patch" \
+ "${FILESDIR}/${P}-fix-whatis-entries.patch" \
+ "${FILESDIR}/${P}-fix-data-uuid-from-string.patch"
+
+ if use php; then
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch \
+ "${FILESDIR}/${P}-gentoo-php.patch" \
+ "${FILESDIR}/${P}-php.patch"
+ done
+
+ php-ext-source-r2_src_prepare
+ fi
+}
+
+src_configure() {
+ # Notes:
+ # * collides with e2fstools libs and includes if not moved around
+ # * pgsql-bindings need PostgreSQL-sources and are included since PostgreSQL 8.3
+ econf \
+ --includedir="${EPREFIX}"/usr/include/ossp \
+ --with-dce \
+ --without-pgsql \
+ --without-perl \
+ --without-php \
+ $(use_with cxx) \
+ $(use_enable static-libs static)
+
+ if use php; then
+ php-ext-source-r2_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ cd perl
+ # configure needs the ossp-uuid.la generated by `make` in $S
+ perl-module_src_configure
+ perl-module_src_compile
+ fi
+
+ if use php; then
+ php-ext-source-r2_src_compile
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS"
+ default
+
+ if use perl ; then
+ cd perl
+ perl-module_src_install
+ fi
+
+ if use php ; then
+ php-ext-source-r2_src_install
+ cd "${S}/php"
+ insinto /usr/share/php
+ newins uuid.php5 uuid.php
+ fi
+
+ use static-libs || rm -rf "${ED}"/usr/lib*/*.la
+
+ mv "${ED}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
+ mv "${ED}/usr/share/man/man3"/uuid.3{,ossp}
+ mv "${ED}/usr/share/man/man3"/uuid++.3{,ossp}
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/.libs" # required for the perl-bindings to load the (correct) library
+ default
+
+ use perl && emake -C perl test
+}