summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-21 00:22:20 +0000
committerSam James <sam@gentoo.org>2022-03-21 00:22:20 +0000
commitde947d37169c0a3e426bfb892f84388fbbfc1fa3 (patch)
treec19bcd8d4fadfcb2dd742ceae79203c37d0587f9 /dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
parentdev-util/ebuildtester: Enable tests (diff)
downloadgentoo-de947d37169c0a3e426bfb892f84388fbbfc1fa3.tar.gz
gentoo-de947d37169c0a3e426bfb892f84388fbbfc1fa3.tar.bz2
gentoo-de947d37169c0a3e426bfb892f84388fbbfc1fa3.zip
dev-libs/ossp-uuid: use canonical phase ordering
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
index 1054159a937a..90dbbbf5b19e 100644
--- a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
@@ -53,19 +53,27 @@ src_compile() {
default
if use perl; then
- cd perl
+ cd perl || die
# configure needs the ossp-uuid.la generated by `make` in $S
perl-module_src_configure
perl-module_src_compile
fi
}
+src_test() {
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${S}/.libs" # required for the perl-bindings to load the (correct) library
+ default
+
+ use perl && emake -C perl test
+}
+
src_install() {
local DOCS=( AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS )
default
unset DOCS #unset so that other eclasses don't try to install them and possibly fail
+
if use perl ; then
- cd perl
+ cd perl || die
perl-module_src_install
fi
@@ -75,10 +83,3 @@ src_install() {
mv "${ED}/usr/share/man/man3"/uuid.3{,ossp}
mv "${ED}/usr/share/man/man3"/uuid++.3{,ossp}
}
-
-src_test() {
- export LD_LIBRARY_PATH="${S}/.libs" # required for the perl-bindings to load the (correct) library
- default
-
- use perl && emake -C perl test
-}