summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/pkcs11-helper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/pkcs11-helper')
-rw-r--r--dev-libs/pkcs11-helper/Manifest1
-rw-r--r--dev-libs/pkcs11-helper/metadata.xml11
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.11.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/pkcs11-helper/Manifest b/dev-libs/pkcs11-helper/Manifest
new file mode 100644
index 000000000000..09868444195c
--- /dev/null
+++ b/dev-libs/pkcs11-helper/Manifest
@@ -0,0 +1 @@
+DIST pkcs11-helper-1.11.tar.bz2 380697 SHA256 05a078efe1261247f26751fa616de732a64dbe1ed6c83e8ea5e6e85d8f70ff2f SHA512 cab34a6c3336cf4077d5b7face9e4b8eeb12f0edb6e265704e481b5ef9738495a45d61a99153b244a91960ed353d79edb99b30f01b0e00efc524542c2a1ac4e1 WHIRLPOOL 8deacedebef01974faecc6861bee27626317379d922f774758fcbd1ec93cf4dc5d1a335144fe85764e92ed985193b5b81b8439b54c953e201b0f17e6b44f4cc8
diff --git a/dev-libs/pkcs11-helper/metadata.xml b/dev-libs/pkcs11-helper/metadata.xml
new file mode 100644
index 000000000000..0f458687a8b8
--- /dev/null
+++ b/dev-libs/pkcs11-helper/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <use>
+ <flag name="nss">Enable NSS crypto engine</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">opensc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.11.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.11.ebuild
new file mode 100644
index 000000000000..dee06e31f68d
--- /dev/null
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="PKCS#11 helper library"
+HOMEPAGE="http://www.opensc-project.org/opensc/wiki/pkcs11-helper"
+SRC_URI="mirror://sourceforge/opensc/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="doc gnutls nss static-libs"
+
+RDEPEND=">=dev-libs/openssl-0.9.7
+ gnutls? ( >=net-libs/gnutls-1.4.4 )
+ nss? ( dev-libs/nss )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable doc) \
+ $(use_enable gnutls crypto-engine-gnutls) \
+ $(use_enable nss crypto-engine-nss) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}