summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-08-22 20:28:47 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-08-22 20:29:19 +0300
commite60ab0b2d94f5307bf6c6c056bd5487a38ab008e (patch)
treec1dca991cf669ab1367e716a286d1c3f9dd9db25 /dev-libs/pkcs11-helper
parentnet-libs/loudmouth: properly get rid of gtk-doc dep (diff)
downloadgentoo-e60ab0b2d94f5307bf6c6c056bd5487a38ab008e.tar.gz
gentoo-e60ab0b2d94f5307bf6c6c056bd5487a38ab008e.tar.bz2
gentoo-e60ab0b2d94f5307bf6c6c056bd5487a38ab008e.zip
dev-libs/pkcs11-helper: build with openssl bindist
Closes: https://bugs.gentoo.org/664086 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/pkcs11-helper')
-rw-r--r--dev-libs/pkcs11-helper/files/pkcs11-helper-1.25.1-build.patch33
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild4
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/pkcs11-helper/files/pkcs11-helper-1.25.1-build.patch b/dev-libs/pkcs11-helper/files/pkcs11-helper-1.25.1-build.patch
new file mode 100644
index 000000000000..a657dba14ce2
--- /dev/null
+++ b/dev-libs/pkcs11-helper/files/pkcs11-helper-1.25.1-build.patch
@@ -0,0 +1,33 @@
+From 0e2ae10ef9611beef92457171e8c78d8e936dfca Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 22 Aug 2018 20:24:19 +0300
+Subject: [PATCH] openssl: build with openssl ec disabled
+
+---
+ ChangeLog | 1 +
+ lib/pkcs11h-openssl.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/lib/pkcs11h-openssl.c b/lib/pkcs11h-openssl.c
+index c981e21..4ebc211 100644
+--- a/lib/pkcs11h-openssl.c
++++ b/lib/pkcs11h-openssl.c
+@@ -263,6 +263,7 @@ DSA_SIG_set0 (DSA_SIG *sig, BIGNUM *r, BIGNUM *s)
+ }
+ #endif
+
++#ifdef __ENABLE_EC
+ #ifndef HAVE_ECDSA_SIG_SET0
+ static int
+ ECDSA_SIG_set0 (ECDSA_SIG *sig, BIGNUM *r, BIGNUM *s)
+@@ -275,7 +276,6 @@ ECDSA_SIG_set0 (ECDSA_SIG *sig, BIGNUM *r, BIGNUM *s)
+ }
+ #endif
+
+-#ifdef __ENABLE_EC
+ #ifndef HAVE_EC_KEY_METHOD_GET_SIGN
+ void EC_KEY_METHOD_get_sign(const EC_KEY_METHOD *meth,
+ int (**psign)(int type, const unsigned char *dgst,
+--
+2.16.4
+
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild
index 5cf68a2ebbf9..976039d39007 100644
--- a/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild
@@ -23,6 +23,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( >=app-doc/doxygen-1.4.7 )"
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
src_configure() {
econf \
--disable-crypto-engine-polarssl \