summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-22 22:40:16 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-22 17:00:37 -0400
commitc10205d7e2b4fd6b35901c7adb9059f0711b4d65 (patch)
tree7ffa2d910f9c5bbda9eb1d7ae845f6590371c730 /dev-libs/protobuf
parentsci-biology/goby: Fix path to protobuf-java in EANT_GENTOO_CLASSPATH. (diff)
downloadgentoo-c10205d7e2b4fd6b35901c7adb9059f0711b4d65.tar.gz
gentoo-c10205d7e2b4fd6b35901c7adb9059f0711b4d65.tar.bz2
gentoo-c10205d7e2b4fd6b35901c7adb9059f0711b4d65.zip
dev-libs/protobuf: Fix building with USE="emacs" (bug #631686).
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/protobuf-3.4.1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-libs/protobuf/protobuf-3.4.1.ebuild b/dev-libs/protobuf/protobuf-3.4.1.ebuild
index d4a2ba85c2d1..ab347e7227c1 100644
--- a/dev-libs/protobuf/protobuf-3.4.1.ebuild
+++ b/dev-libs/protobuf/protobuf-3.4.1.ebuild
@@ -53,16 +53,20 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
+src_compile() {
+ multilib-minimal_src_compile
+
+ if use emacs; then
+ elisp-compile editors/protobuf-mode.el
+ fi
+}
+
multilib_src_compile() {
if tc-is-cross-compiler; then
emake -C "${WORKDIR}/build/src" protoc
fi
default
-
- if use emacs; then
- elisp-compile editors/protobuf-mode.el
- fi
}
multilib_src_test() {