summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-09-07 15:37:27 -0400
committerSam James <sam@gentoo.org>2022-09-10 12:33:12 +0100
commitfe7fbdb2f6a747fac2d547b8f2c22a31bdddc2f1 (patch)
tree9d26b52ac037ef478ad11d258d65f31eed165cb2 /dev-libs/pugixml/pugixml-1.12.ebuild
parentapp-misc/pax-utils: Stabilize 1.3.5 sparc, #867613 (diff)
downloadgentoo-fe7fbdb2f6a747fac2d547b8f2c22a31bdddc2f1.tar.gz
gentoo-fe7fbdb2f6a747fac2d547b8f2c22a31bdddc2f1.tar.bz2
gentoo-fe7fbdb2f6a747fac2d547b8f2c22a31bdddc2f1.zip
dev-libs/pugixml: enable tests
The release tarball excludes the test sources, so switch SRC_URI to the github tag archive. Closes: https://github.com/gentoo/gentoo/pull/27184 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.12.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.12.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/pugixml/pugixml-1.12.ebuild b/dev-libs/pugixml/pugixml-1.12.ebuild
index ebcd674be6c0..75d80895d193 100644
--- a/dev-libs/pugixml/pugixml-1.12.ebuild
+++ b/dev-libs/pugixml/pugixml-1.12.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/zeux/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
fi
@@ -18,3 +18,12 @@ HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml"
LICENSE="MIT"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -D${PN^^}_BUILD_TESTS=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}