summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-19 23:39:24 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-19 23:42:41 +1000
commit076fdccdd0a98e10439c819b4363efe4b17c2273 (patch)
treea870493e3dfd6272b6aa5457e030d25cd2ad5b9f /dev-libs/purpose/purpose-1.1-r1.ebuild
parentsci-physics/root: remove old (diff)
downloadgentoo-076fdccdd0a98e10439c819b4363efe4b17c2273.tar.gz
gentoo-076fdccdd0a98e10439c819b4363efe4b17c2273.tar.bz2
gentoo-076fdccdd0a98e10439c819b4363efe4b17c2273.zip
dev-libs/purpose: revision bump to add Qt subslot operator
The QT_VERSION_CHECK macro is used at build-time. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs/purpose/purpose-1.1-r1.ebuild')
-rw-r--r--dev-libs/purpose/purpose-1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/purpose/purpose-1.1-r1.ebuild b/dev-libs/purpose/purpose-1.1-r1.ebuild
new file mode 100644
index 000000000000..212830a9b31b
--- /dev/null
+++ b/dev-libs/purpose/purpose-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.6.0
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+"
+RDEPEND="${DEPEND}"