summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-03-31 22:14:00 +1100
committerMichael Palimaka <kensington@gentoo.org>2019-03-31 22:14:17 +1100
commita1a68837a5e59deda2cb51441f3f24c7fc63f173 (patch)
tree02747efffd8a4a9fe585f41bbd855e1393a98b85 /dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild
parentpackage.mask: Last rite sci-chemistry/ball (diff)
downloadgentoo-a1a68837a5e59deda2cb51441f3f24c7fc63f173.tar.gz
gentoo-a1a68837a5e59deda2cb51441f3f24c7fc63f173.tar.bz2
gentoo-a1a68837a5e59deda2cb51441f3f24c7fc63f173.zip
dev-libs/qcustomplot: version bump 2.0.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild')
-rw-r--r--dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild b/dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild
new file mode 100644
index 000000000000..51051c6445ad
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="https://www.qcustomplot.com/"
+SRC_URI="
+ https://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ https://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-source
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}