summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-17 05:38:59 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-02-25 11:38:28 +1100
commit618d97a850aa4b933f47817cc3ed109fec928808 (patch)
tree0bb44daee3edd68c9d1c29718d1b6097d868e2be /dev-libs/qrosspython/qrosspython-9999.ebuild
parentdev-libs/qrosscore: build 9999 with Qt5 (diff)
downloadgentoo-618d97a850aa4b933f47817cc3ed109fec928808.tar.gz
gentoo-618d97a850aa4b933f47817cc3ed109fec928808.tar.bz2
gentoo-618d97a850aa4b933f47817cc3ed109fec928808.zip
dev-libs/qrosspython: build 9999 with Qt5
Diffstat (limited to 'dev-libs/qrosspython/qrosspython-9999.ebuild')
-rw-r--r--dev-libs/qrosspython/qrosspython-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-libs/qrosspython/qrosspython-9999.ebuild b/dev-libs/qrosspython/qrosspython-9999.ebuild
index 9788aa580120..40f7f404ce49 100644
--- a/dev-libs/qrosspython/qrosspython-9999.ebuild
+++ b/dev-libs/qrosspython/qrosspython-9999.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-EGIT_REPO_URI="git://github.com/0xd34df00d/Qross.git"
inherit git-r3 python-single-r1 cmake-utils
+EGIT_REPO_URI="git://github.com/0xd34df00d/Qross.git"
+
DESCRIPTION="Python scripting backend for Qross"
HOMEPAGE="https://github.com/0xd34df00d/Qross"
@@ -20,14 +21,16 @@ IUSE="debug"
RDEPEND="
~dev-libs/qrosscore-${PV}
dev-python/sip
- dev-qt/qtcore:4
- dev-qt/qtgui:4
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
- dev-qt/qttest:4
+ dev-qt/qttest:5
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
CMAKE_USE_DIR="${S}/src/bindings/python/qrosspython"
+
+mycmakeargs=( -DUSE_QT5=ON )