summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/qtkeychain
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/qtkeychain')
-rw-r--r--dev-libs/qtkeychain/Manifest1
-rw-r--r--dev-libs/qtkeychain/metadata.xml11
-rw-r--r--dev-libs/qtkeychain/qtkeychain-0.5.0.ebuild64
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/qtkeychain/Manifest b/dev-libs/qtkeychain/Manifest
new file mode 100644
index 000000000000..670b00df21e8
--- /dev/null
+++ b/dev-libs/qtkeychain/Manifest
@@ -0,0 +1 @@
+DIST qtkeychain-0.5.0.tar.gz 18422 SHA256 e62d7ae9c8ae04784d8a5d0f213aaa22f1c02427e800ce88739e997f499bb514 SHA512 abc9d27b318a984c95b55f821f8bba7d8f34e6316958cf41b44aa4451371e5f629f17b9a0d1356cd6455f19979d562157a260f835c8f037037b0ac7bf64b94e5 WHIRLPOOL b3c99c863390b8c9e807a17783ca95640a468d57eec35e197412a46031aae06433e06c3274973e7876192a654e09cba6bd92512baf8a3500052a3de9d1a50496
diff --git a/dev-libs/qtkeychain/metadata.xml b/dev-libs/qtkeychain/metadata.xml
new file mode 100644
index 000000000000..bf95f9645b6b
--- /dev/null
+++ b/dev-libs/qtkeychain/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">frankosterfeld/qtkeychain</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/qtkeychain/qtkeychain-0.5.0.ebuild b/dev-libs/qtkeychain/qtkeychain-0.5.0.ebuild
new file mode 100644
index 000000000000..fd307c0a2ba2
--- /dev/null
+++ b/dev-libs/qtkeychain/qtkeychain-0.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multibuild
+
+DESCRIPTION="Qt API for storing passwords securely"
+HOMEPAGE="https://github.com/frankosterfeld/qtkeychain"
+SRC_URI="https://github.com/frankosterfeld/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+qt4 qt5"
+
+REQUIRED_USE="|| ( qt4 qt5 )"
+
+RDEPEND="
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ )
+"
+DEPEND="${RDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+DOCS=( ChangeLog ReadMe.txt )
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt4) $(usev qt5) )
+}
+
+src_configure() {
+ myconfigure() {
+ if [[ ${MULTIBUILD_VARIANT} = qt4 ]]; then
+ local mycmakeargs=(-DBUILD_WITH_QT4=ON)
+ fi
+ if [[ ${MULTIBUILD_VARIANT} = qt5 ]]; then
+ local mycmakeargs=(-DBUILD_WITH_QT4=OFF)
+ fi
+ cmake-utils_src_configure
+ }
+
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake-utils_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake-utils_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake-utils_src_install
+}