summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-20 14:22:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-20 15:03:25 +0200
commit8d40e5767c67082e1f69117553766ad1a3614354 (patch)
treeee13cdc883cf18642d851081da6e1f4bb684856c /dev-libs/quazip/quazip-0.7.6.ebuild
parentkde-plasma/plasma-nm: Fix cmake options (diff)
downloadgentoo-8d40e5767c67082e1f69117553766ad1a3614354.tar.gz
gentoo-8d40e5767c67082e1f69117553766ad1a3614354.tar.bz2
gentoo-8d40e5767c67082e1f69117553766ad1a3614354.zip
dev-libs/quazip: 0.7.6 version bump, moved to GitHub
Bug: https://bugs.gentoo.org/658548 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/quazip/quazip-0.7.6.ebuild')
-rw-r--r--dev-libs/quazip/quazip-0.7.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/quazip/quazip-0.7.6.ebuild b/dev-libs/quazip/quazip-0.7.6.ebuild
new file mode 100644
index 000000000000..e9f4d698d203
--- /dev/null
+++ b/dev-libs/quazip/quazip-0.7.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic qmake-utils
+
+DESCRIPTION="Simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
+HOMEPAGE="https://stachenov.github.io/quazip/"
+SRC_URI="https://github.com/stachenov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if ! use static-libs ; then
+ sed -e "/^install/ s/quazip_static//" -i CMakeLists.txt || die
+ fi
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local -x CXXFLAGS="${CXXFLAGS}"
+ append-cxxflags -std=c++11 -fPIC
+
+ local mycmakeargs=(
+ -DBUILD_WITH_QT4=OFF
+ -DLIB_SUFFIX=${libdir/lib/}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # compatibility with not yet fixed rdeps (Gentoo bug #598136)
+ dosym libquazip5.so /usr/$(get_libdir)/libquazip.so
+}