summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-10 18:58:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-13 02:29:09 +0200
commit98532a89b0351b032404c1f8658ed83d73641428 (patch)
treee3fa72293eef9fa5128065d0b5783ed09139ad49 /dev-libs/quazip/quazip-0.9.1.ebuild
parentapp-accessibility/speech-dispatcher: Drop 0.8.7-r2 (diff)
downloadgentoo-98532a89b0351b032404c1f8658ed83d73641428.tar.gz
gentoo-98532a89b0351b032404c1f8658ed83d73641428.tar.bz2
gentoo-98532a89b0351b032404c1f8658ed83d73641428.zip
dev-libs/quazip: 0.9.1 version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/quazip/quazip-0.9.1.ebuild')
-rw-r--r--dev-libs/quazip/quazip-0.9.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/quazip/quazip-0.9.1.ebuild b/dev-libs/quazip/quazip-0.9.1.ebuild
new file mode 100644
index 000000000000..c7116322243d
--- /dev/null
+++ b/dev-libs/quazip/quazip-0.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic qmake-utils
+
+DESCRIPTION="Simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
+HOMEPAGE="https://stachenov.github.io/quazip/"
+SRC_URI="https://github.com/stachenov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-static-lib.patch"
+ "${FILESDIR}/${P}-pkgconfig.patch"
+)
+
+src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_SUFFIX=${libdir/lib/}
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # compatibility with not yet fixed rdeps (Gentoo bug #598136)
+ dosym libquazip5.so /usr/$(get_libdir)/libquazip.so
+}