summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-02-10 09:39:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-02-10 09:39:27 +0200
commit6c1e3bac4e7b3fdcb3195e053d4979d22ff29ff2 (patch)
tree31a91548129d68108b410a58a5727a697b410f50 /dev-libs/raft/raft-0.21.0.ebuild
parentdev-libs/raft: add 0.22.0 (diff)
downloadgentoo-6c1e3bac4e7b3fdcb3195e053d4979d22ff29ff2.tar.gz
gentoo-6c1e3bac4e7b3fdcb3195e053d4979d22ff29ff2.tar.bz2
gentoo-6c1e3bac4e7b3fdcb3195e053d4979d22ff29ff2.zip
dev-libs/raft: drop 0.18.3, 0.20.0, 0.21.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/raft/raft-0.21.0.ebuild')
-rw-r--r--dev-libs/raft/raft-0.21.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-libs/raft/raft-0.21.0.ebuild b/dev-libs/raft/raft-0.21.0.ebuild
deleted file mode 100644
index 4b51fe639271..000000000000
--- a/dev-libs/raft/raft-0.21.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="C implementation of the Raft consensus protocol"
-HOMEPAGE="https://github.com/cowsql/raft"
-SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3-with-linking-exception"
-
-# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
-SLOT="0/0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="lz4 test zfs"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-libs/libuv:=
- lz4? ( app-arch/lz4:= )"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # --disable-hardening: most of these are covered on non-hardened Gentoo already.
- local myeconfargs=(
- --enable-uv
- --enable-v0
-
- --disable-backtrace
- --disable-benchmark
- --disable-debug
- --disable-example
- --disable-hardening
- --disable-sanitize
- --disable-static
-
- $(use_enable test fixture)
-
- $(use_with lz4)
- $(use_with zfs)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}