summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-03-27 23:09:35 -0400
committerDavid Seifert <soap@gentoo.org>2017-04-01 12:20:41 +0200
commitbb5ceff1f0b6a70c7e01ca566f14c33406556578 (patch)
treeb7a9a730f2c1a5e1a1b61c4eb3613ee7a051245c /dev-libs/rapidjson/rapidjson-9999.ebuild
parentmail-client/roundcube: add ~ppc64 keyword (bug 594824). (diff)
downloadgentoo-bb5ceff1f0b6a70c7e01ca566f14c33406556578.tar.gz
gentoo-bb5ceff1f0b6a70c7e01ca566f14c33406556578.tar.bz2
gentoo-bb5ceff1f0b6a70c7e01ca566f14c33406556578.zip
dev-libs/rapidjson: A fast JSON parser/generator for C++ with both SAX/DOM style API
Gentoo-bug: 614100 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4310
Diffstat (limited to 'dev-libs/rapidjson/rapidjson-9999.ebuild')
-rw-r--r--dev-libs/rapidjson/rapidjson-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/rapidjson/rapidjson-9999.ebuild b/dev-libs/rapidjson/rapidjson-9999.ebuild
new file mode 100644
index 000000000000..8f3a254b7911
--- /dev/null
+++ b/dev-libs/rapidjson/rapidjson-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A fast JSON parser/generator for C++ with both SAX/DOM style API"
+HOMEPAGE="http://rapidjson.org/"
+
+LICENSE="MIT"
+IUSE="doc examples test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/miloyip/rapidjson.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/miloyip/rapidjson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/rapidjson-${PV}"
+fi
+
+DEPEND="
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-cpp/gtest
+ dev-util/valgrind
+ )"
+RDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DRAPIDJSON_BUILD_DOC=$(usex doc)
+ -DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
+ -DRAPIDJSON_BUILD_TESTS=$(usex test)
+ -DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
+ )
+ cmake-utils_src_configure
+}