summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-25 08:53:12 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-25 08:59:00 +0200
commitbe5be686ab3d53aaa6a2b42f0f63cd05ca5f0c3e (patch)
tree51199ebf55062c0bcb42cf08ed2eff6132f26e2f /dev-libs/redland-bindings/files
parentsys-fs/lvm2: Bump to version 2.03.06. Removed old (diff)
downloadgentoo-be5be686ab3d53aaa6a2b42f0f63cd05ca5f0c3e.tar.gz
gentoo-be5be686ab3d53aaa6a2b42f0f63cd05ca5f0c3e.tar.bz2
gentoo-be5be686ab3d53aaa6a2b42f0f63cd05ca5f0c3e.zip
dev-libs/redland-bindings: Version bump, no keywords. Perl works. Bug 526158
Bug: https://bugs.gentoo.org/526158 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-libs/redland-bindings/files')
-rw-r--r--dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch22
-rw-r--r--dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch34
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch b/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch
new file mode 100644
index 000000000000..35594515c793
--- /dev/null
+++ b/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-bool.patch
@@ -0,0 +1,22 @@
+From: =?utf-8?q?Ond=C5=99ej_Sur=C3=BD?= <ondrej@sury.org>
+Date: Wed, 22 Jun 2016 10:28:48 +0200
+Subject: Don't undef bool, it's needed
+
+---
+ perl/CORE_wrap.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/perl/CORE_wrap.c b/perl/CORE_wrap.c
+index 46c2a46..4eb3785 100644
+--- a/perl/CORE_wrap.c
++++ b/perl/CORE_wrap.c
+@@ -1432,9 +1432,6 @@ SWIG_Perl_SetModule(swig_module_info *module) {
+ #ifdef eof
+ #undef eof
+ #endif
+-#ifdef bool
+- #undef bool
+-#endif
+ #ifdef close
+ #undef close
+ #endif
diff --git a/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch b/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch
new file mode 100644
index 000000000000..1ca8ded91e9f
--- /dev/null
+++ b/dev-libs/redland-bindings/files/redland-bindings-1.0.17.1-php-config.patch
@@ -0,0 +1,34 @@
+diff -aurN a/configure.ac b/configure.ac
+--- a/configure.ac 2014-05-10 18:38:09.000000000 -0400
++++ b/configure.ac 2016-10-12 14:27:04.635849601 -0400
+@@ -153,13 +153,17 @@
+ fi
+ fi
+
++AC_ARG_WITH([php-config],
++ AS_HELP_STRING([--with-php-config=path], [Custom path to php-config]))
++AS_IF([test "x$with_php_config" != "x"],
++ [AC_CHECK_PROG(PHP_CONFIG, php-config, ["$with_php_config/php-config"], [], [$with_php_config])],
++ [AC_CHECK_PROG(PHP_CONFIG, php-config, php-config)])
+
+-AC_CHECK_PROG(PHP_CONFIG, php-config, php-config)
+ if test "X$PHP_CONFIG" != X ; then
+
+- PHP_VERSION=`$PHP_CONFIG --version`
+- PHP_INCLUDES=`$PHP_CONFIG --includes`
+- PHP_EXTENSION_DIR=`$PHP_CONFIG --extension-dir`
++ PHP_VERSION=`${PHP_CONFIG} --version`
++ PHP_INCLUDES=`${PHP_CONFIG} --includes`
++ PHP_EXTENSION_DIR=`${PHP_CONFIG} --extension-dir`
+
+ if test $PHP_VERSION '>' 5.0.0; then
+ PHP_SWIG="-php5"
+@@ -445,7 +449,7 @@
+ with_php=yes
+ fi
+
+-PHP_VERSION=`php-config --version 2>/dev/null`
++PHP_VERSION=`${PHP_CONFIG} --version 2>/dev/null`
+ if test "X$PHP_VERSION" != X; then
+ languages_available="$languages_available php($PHP_VERSION)"
+ if test $with_php = yes; then