summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-31 13:40:34 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-31 13:44:23 +0100
commitae1c756e5d7576799a2f261d6d432c2d9ff256e8 (patch)
tree637a4b99d8223792be3a0af31d1d3bffd48d4430 /dev-libs/rlog
parentdev-libs/pslib: Port to EAPI 6 (diff)
downloadgentoo-ae1c756e5d7576799a2f261d6d432c2d9ff256e8.tar.gz
gentoo-ae1c756e5d7576799a2f261d6d432c2d9ff256e8.tar.bz2
gentoo-ae1c756e5d7576799a2f261d6d432c2d9ff256e8.zip
dev-libs/rlog: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/rlog')
-rw-r--r--dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch4
-rw-r--r--dev-libs/rlog/files/rlog-1.4-fix-build-system.patch59
-rw-r--r--dev-libs/rlog/rlog-1.4.ebuild21
3 files changed, 76 insertions, 8 deletions
diff --git a/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
index 5e4bb91bf1e3..07770791cd77 100644
--- a/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
+++ b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
@@ -1,5 +1,5 @@
---- rlog/RLogChannel.cpp
-+++ rlog/RLogChannel.cpp
+--- a/rlog/RLogChannel.cpp
++++ b/rlog/RLogChannel.cpp
@@ -20,6 +20,7 @@
#include "RLogChannel.h"
#include "rlog.h"
diff --git a/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch b/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..b7959a79cd02
--- /dev/null
+++ b/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
@@ -0,0 +1,59 @@
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
+@@ -1,15 +1,13 @@
+
+ SOURCES = index.dox channel.dox component.dox
+
+-docdir = $(datadir)/doc
+-pkgdocdir = $(docdir)/$(PACKAGE)
+ #pkghtmldir = $(pkgdocdir)/html
+
+
+ # have both html and html/index.html to force build of index.html if necessary
+ EXTRA_DIST = latex/refman.pdf html html/index.html $(SOURCES)
+
+-pkgdoc_DATA = \
++pdf_DATA = \
+ latex/refman.pdf
+
+ #pkghtml_DATA = \
+@@ -17,22 +15,21 @@
+
+ if BUILD_DOCS
+ latex/refman.pdf: html/index.html
+- -cd latex && make
++ $(MAKE) -C latex
+
+ html/index.html: ../Doxyfile $(SOURCES)
+- -rm -rf html
+- -cd .. && @DOXYGEN@ Doxyfile
++ rm -rf html && $(DOXYGEN) Doxyfile
+
+ clean-local:
+- -rm -rf html
+- -rm -rf latex
++ rm -rf html
++ rm -rf latex
+ endif
+
+ all-local: html/index.html
+
+-install-data-local: all-local
+- -echo installing to ${DESTDIR}${pkgdocdir}/html
+- /bin/sh ../mkinstalldirs ${DESTDIR}${pkgdocdir}/html
+- install html/* ${DESTDIR}${pkgdocdir}/html
++install-data-hook: all-local
++ -echo installing to $(DESTDIR)$(htmldir)
++ /bin/sh ../mkinstalldirs $(DESTDIR)$(htmldir)
++ install html/* $(DESTDIR)$(htmldir)
+
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,6 +10,3 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = librlog.pc
+
+-documentation:
+- cd docs && make
+-
diff --git a/dev-libs/rlog/rlog-1.4.ebuild b/dev-libs/rlog/rlog-1.4.ebuild
index c24fabb7a48c..0a937d761f36 100644
--- a/dev-libs/rlog/rlog-1.4.ebuild
+++ b/dev-libs/rlog/rlog-1.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
+
+inherit autotools
DESCRIPTION="A C++ logging library"
HOMEPAGE="http://www.arg0.net/rlog"
@@ -13,11 +14,19 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc sparc x86"
IUSE=""
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
+ "${FILESDIR}"/${PN}-1.4-fix-build-system.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
+ default
+ eautoreconf
}
src_install() {
- emake DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install || die
- dodoc AUTHORS ChangeLog README
+ default
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
}