summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-27 11:35:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-27 11:36:00 +0000
commit27f6896d7e495252f13d593315ea02a00ee57899 (patch)
tree164775c923dec0cbac1d7b856d4e894f05377d1d /dev-libs/rocm-device-libs/rocm-device-libs-4.1.0.ebuild
parentdev-libs/libnatspec: Port to EAPI 7 (diff)
downloadgentoo-27f6896d7e495252f13d593315ea02a00ee57899.tar.gz
gentoo-27f6896d7e495252f13d593315ea02a00ee57899.tar.bz2
gentoo-27f6896d7e495252f13d593315ea02a00ee57899.zip
dev-libs/rocm-device-libs: Bump to 4.1.0
Mix of different versions can cause spurious build failures. This brings it to same version with llvm-roc etc. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-device-libs/rocm-device-libs-4.1.0.ebuild')
-rw-r--r--dev-libs/rocm-device-libs/rocm-device-libs-4.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/rocm-device-libs/rocm-device-libs-4.1.0.ebuild b/dev-libs/rocm-device-libs/rocm-device-libs-4.1.0.ebuild
new file mode 100644
index 000000000000..94bddf83d919
--- /dev/null
+++ b/dev-libs/rocm-device-libs/rocm-device-libs-4.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-Device-Libs-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Device Libraries"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-Device-Libs"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/OCL.cmake" || die
+ sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/Packages.cmake" || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
+ )
+ cmake_src_configure
+}