summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-01-06 18:10:52 +0100
committerCraig Andrews <candrews@gentoo.org>2020-01-06 17:10:51 -0500
commitbef1d344ac6f05ba01794ac48658ae214c106dbd (patch)
treeb4e11b3198b742d2e9e0941439095319a272ec0b /dev-libs/rocm-opencl-driver
parentmedia-plugins/kodi-inputstream-adaptive: Use the "Matrix" branch (diff)
downloadgentoo-bef1d344ac6f05ba01794ac48658ae214c106dbd.tar.gz
gentoo-bef1d344ac6f05ba01794ac48658ae214c106dbd.tar.bz2
gentoo-bef1d344ac6f05ba01794ac48658ae214c106dbd.zip
dev-libs/rocm-opencl-driver: remove unused patch(es)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14268 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-opencl-driver')
-rw-r--r--dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-correctly.patch49
-rw-r--r--dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-header.patch19
-rw-r--r--dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch40
3 files changed, 0 insertions, 108 deletions
diff --git a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-correctly.patch b/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-correctly.patch
deleted file mode 100644
index d70f0977ec8f..000000000000
--- a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-correctly.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-https://github.com/RadeonOpenCompute/ROCm-OpenCL-Driver/pull/85
-
-From 8819a684c9b6e154abedc041b3da545aab353d67 Mon Sep 17 00:00:00 2001
-From: Craig Andrews <candrews@integralblue.com>
-Date: Fri, 26 Jul 2019 15:54:59 -0400
-Subject: [PATCH] Use GNUInstallDirs to install to standard locations
-
-Some distributions require 64 bit libraries to be installed to lib64, for example.
-Using GNUInstallDirs ensures that files are installed to the expected locations.
----
- CMakeLists.txt | 3 +++
- src/driver/CMakeLists.txt | 2 +-
- src/roc-cl/CMakeLists.txt | 2 +-
- 3 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d1759b7..d21e9da 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -42,6 +42,9 @@
-
- cmake_minimum_required(VERSION 2.8)
-
-+## Include common cmake modules
-+include ( GNUInstallDirs )
-+
- # Build ROCm-OpenCL-Driver with ccache if the package is present.
- set(ROCM_OPENCL_DRIVER_CCACHE_BUILD OFF CACHE BOOL "Set to ON for a ccache enabled build")
- if(ROCM_OPENCL_DRIVER_CCACHE_BUILD)
-diff --git a/src/driver/CMakeLists.txt b/src/driver/CMakeLists.txt
-index 7046e34..55ed13f 100644
---- a/src/driver/CMakeLists.txt
-+++ b/src/driver/CMakeLists.txt
-@@ -90,4 +90,4 @@ target_link_libraries(opencl_driver
- target_link_libraries(opencl_driver ${llvm_libs})
- target_include_directories(opencl_driver PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
-
--install(TARGETS opencl_driver DESTINATION lib)
-+install(TARGETS opencl_driver DESTINATION ${CMAKE_INSTALL_LIBDIR} )
-diff --git a/src/roc-cl/CMakeLists.txt b/src/roc-cl/CMakeLists.txt
-index 5037453..a8e2801 100644
---- a/src/roc-cl/CMakeLists.txt
-+++ b/src/roc-cl/CMakeLists.txt
-@@ -54,4 +54,4 @@ link_directories(${LLVM_LIBRARY_DIRS})
- add_executable(roc-cl ${sources})
- target_link_libraries(roc-cl opencl_driver)
-
--install(TARGETS roc-cl RUNTIME DESTINATION bin)
-+install(TARGETS roc-cl RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} )
diff --git a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-header.patch b/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-header.patch
deleted file mode 100644
index b37100994e04..000000000000
--- a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.6.0-install-header.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From 1258a99decf96092de8ea512150209e14152ed9c Mon Sep 17 00:00:00 2001
-From: Craig Andrews <candrews@integralblue.com>
-Date: Tue, 30 Jul 2019 16:46:20 -0400
-Subject: [PATCH] Install AmdCompiler.h header
-
-ROCm-OpenCL-Runtime uses AmdCompiler.h so it should be installed to the system and made available for use
----
- src/driver/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/driver/CMakeLists.txt b/src/driver/CMakeLists.txt
-index 55ed13f..8f68fb7 100644
---- a/src/driver/CMakeLists.txt
-+++ b/src/driver/CMakeLists.txt
-@@ -91,3 +91,4 @@ target_link_libraries(opencl_driver ${llvm_libs})
- target_include_directories(opencl_driver PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
-
- install(TARGETS opencl_driver DESTINATION ${CMAKE_INSTALL_LIBDIR} )
-+install(FILES AmdCompiler.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
diff --git a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch b/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch
deleted file mode 100644
index 9e2a06aac979..000000000000
--- a/dev-libs/rocm-opencl-driver/files/rocm-opencl-driver-2.7.0-libraries.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-https://github.com/RadeonOpenCompute/ROCm-OpenCL-Driver/pull/88
-
-From f49ad81e246f1c196cf86f40cf44dfedec0675f1 Mon Sep 17 00:00:00 2001
-From: Mike Lothain <mike@fireburn.co.uk>
-Date: Tue, 27 Aug 2019 11:32:47 +0100
-Subject: [PATCH] Include more link libraries
-
-This is required to get dev-libs/rocm-opencl-driver-2.7.0 compiling for me on Gentoo
-
-I think it might be related to using -Wl,--as-needed in my link flags globally
----
- src/driver/CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/driver/CMakeLists.txt b/src/driver/CMakeLists.txt
-index 55ed13f..b93356d 100644
---- a/src/driver/CMakeLists.txt
-+++ b/src/driver/CMakeLists.txt
-@@ -60,9 +60,13 @@ llvm_map_components_to_libnames(llvm_libs
- AllTargetsDescs
- AllTargetsDisassemblers
- AllTargetsInfos
-+ BitWriter
- CodeGen
-+ IRReader
-+ Linker
- MC
- MCDisassembler
-+ MCParser
- Object
- Symbolize
- Core
-@@ -83,6 +87,7 @@ target_link_libraries(opencl_driver
- clangLex
- clangBasic
- clangCodeGen
-+ clangSerialization
- lldELF
- lldCore
- LLVMDebugInfoDWARF