summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-08-23 17:34:36 +0200
committerCraig Andrews <candrews@gentoo.org>2020-08-23 11:30:53 -0400
commit7553658cd43dbd2dfd1eb13ed5be4ecd84d76d40 (patch)
tree7a9e0ca6e2dd433b91fd0a0d69fee3b44e5fe276 /dev-libs/rocm-opencl-runtime/files
parentdev-python/networkx: Bump to 2.5 (diff)
downloadgentoo-7553658cd43dbd2dfd1eb13ed5be4ecd84d76d40.tar.gz
gentoo-7553658cd43dbd2dfd1eb13ed5be4ecd84d76d40.tar.bz2
gentoo-7553658cd43dbd2dfd1eb13ed5be4ecd84d76d40.zip
dev-libs/rocm-opencl-runtime: Version bump to 3.7.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Closes: https://github.com/gentoo/gentoo/pull/17237 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-opencl-runtime/files')
-rw-r--r--dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-add-rocclr-include-directories.patch11
-rw-r--r--dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-amdocl64icd.patch10
-rw-r--r--dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-change-install-location.patch79
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-add-rocclr-include-directories.patch b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-add-rocclr-include-directories.patch
new file mode 100644
index 000000000000..357b97c7f49e
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-add-rocclr-include-directories.patch
@@ -0,0 +1,11 @@
+--- a/amdocl/CMakeLists.txt 2020-08-23 10:11:28.227839351 +0200
++++ b/amdocl/CMakeLists.txt 2020-08-23 10:44:34.929831772 +0200
+@@ -23,6 +23,8 @@
+ include_directories(${CMAKE_SOURCE_DIR}/khronos)
+ include_directories(${CMAKE_SOURCE_DIR}/khronos/headers)
+ include_directories(${CMAKE_SOURCE_DIR}/khronos/headers/opencl2.2)
++include_directories(/usr/include/rocclr)
++include_directories(/usr/include/rocclr/compiler/lib/include/)
+
+ if((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR
+ (CMAKE_${COMPILER}_COMPILER_ID MATCHES "Clang"))
diff --git a/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-amdocl64icd.patch b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-amdocl64icd.patch
new file mode 100644
index 000000000000..6541c69bd48a
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-amdocl64icd.patch
@@ -0,0 +1,10 @@
+--- a/amdocl/CMakeLists.txt 2020-08-23 10:11:28.227839351 +0200
++++ b/amdocl/CMakeLists.txt 2020-08-23 10:12:03.697839216 +0200
+@@ -76,3 +76,7 @@
+ add_library(amdocl64 SHARED ${amdocl64_src})
+
+ target_link_libraries(amdocl64 amdrocclr_static Threads::Threads dl ${ADDITIONAL_LIBRARIES})
++
++file(GENERATE OUTPUT "${CMAKE_BINARY_DIR}/amdocl64.icd" CONTENT "$<TARGET_FILE_NAME:amdocl64>")
++install(FILES "${CMAKE_BINARY_DIR}/amdocl64.icd" DESTINATION "${CMAKE_INSTALL_FULL_SYSCONFDIR}/OpenCL/vendors/")
++
diff --git a/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-change-install-location.patch b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-change-install-location.patch
new file mode 100644
index 000000000000..77ce5e9bd332
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-change-install-location.patch
@@ -0,0 +1,79 @@
+--- a/CMakeLists.txt 2020-08-23 10:14:54.337838565 +0200
++++ b/CMakeLists.txt 2020-08-23 10:18:26.993837753 +0200
+@@ -14,6 +14,8 @@
+ #example command:
+ # cmake -DCMAKE_PREFIX_PATH=/path/to/ROCclr/build/or/install ..
+
++include (GNUInstallDirs)
++
+ set(OPENCL_ICD_LOADER_HEADERS_DIR "${CMAKE_CURRENT_SOURCE_DIR}/khronos/headers/opencl2.2" CACHE PATH "")
+ option(BUILD_SHARED_LIBS "Build shared libs" ON)
+
+@@ -60,7 +62,7 @@
+
+ add_subdirectory(khronos/icd)
+ add_subdirectory(amdocl)
+-add_subdirectory(tools/clinfo)
++#add_subdirectory(tools/clinfo)
+ add_subdirectory(tools/cltrace)
+ if(BUILD_TESTS)
+ add_subdirectory(tests/ocltst)
+@@ -96,34 +98,34 @@
+ ###--- Packaging ------------------------------------------------------------###
+
+ # MAIN package
+-install(PROGRAMS $<TARGET_FILE:clinfo>
+- DESTINATION bin
+- COMPONENT MAIN)
+-install(PROGRAMS $<TARGET_FILE:cltrace>
+- DESTINATION lib
+- COMPONENT MAIN)
++#install(PROGRAMS $<TARGET_FILE:clinfo>
++# DESTINATION bin
++# COMPONENT MAIN)
++#install(PROGRAMS $<TARGET_FILE:cltrace>
++# DESTINATION lib
++# COMPONENT MAIN)
+ install(PROGRAMS $<TARGET_FILE:amdocl64>
+- DESTINATION lib
+- COMPONENT MAIN)
+-install(PROGRAMS $<TARGET_FILE:OpenCL>
+- DESTINATION lib
+- COMPONENT MAIN)
+-install(PROGRAMS $<TARGET_SONAME_FILE:OpenCL>
+- DESTINATION lib
++ DESTINATION lib64
+ COMPONENT MAIN)
++#install(PROGRAMS $<TARGET_FILE:OpenCL>
++# DESTINATION lib
++# COMPONENT MAIN)
++#install(PROGRAMS $<TARGET_SONAME_FILE:OpenCL>
++# DESTINATION lib
++# COMPONENT MAIN)
+
+ # DEV package
+-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/khronos/headers/opencl2.2/CL"
+- DESTINATION include
+- COMPONENT DEV
+- USE_SOURCE_PERMISSIONS
+- PATTERN cl_d3d10.h EXCLUDE
+- PATTERN cl_d3d11.h EXCLUDE
+- PATTERN cl_dx9_media_sharing.h EXCLUDE
+- PATTERN cl_egl.h EXCLUDE)
+-install(PROGRAMS $<TARGET_LINKER_FILE:OpenCL>
+- DESTINATION lib
+- COMPONENT DEV)
++#install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/khronos/headers/opencl2.2/CL"
++# DESTINATION include
++# COMPONENT DEV
++# USE_SOURCE_PERMISSIONS
++# PATTERN cl_d3d10.h EXCLUDE
++# PATTERN cl_d3d11.h EXCLUDE
++# PATTERN cl_dx9_media_sharing.h EXCLUDE
++# PATTERN cl_egl.h EXCLUDE)
++#install(PROGRAMS $<TARGET_LINKER_FILE:OpenCL>
++# DESTINATION lib
++# COMPONENT DEV)
+
+ #############################
+ # Packaging steps