summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-15 16:19:29 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-15 16:19:29 -0400
commitd131f25ec9ee02f3b9f223b2018ed7cbf6937589 (patch)
treea74265fdffd33d12ec4a3a900b284227d4a73334 /dev-libs/rocm-opencl-runtime
parentdev-libs/rocm-opencl-runtime: depend on dev-libs/ocl-icd (diff)
downloadgentoo-d131f25ec9ee02f3b9f223b2018ed7cbf6937589.tar.gz
gentoo-d131f25ec9ee02f3b9f223b2018ed7cbf6937589.tar.bz2
gentoo-d131f25ec9ee02f3b9f223b2018ed7cbf6937589.zip
dev-libs/rocm-opencl-runtime: Cleanup old version
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-opencl-runtime')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-2.6.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-2.6.0.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-2.6.0.ebuild
deleted file mode 100644
index cd44ed80e4d7..000000000000
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-2.6.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils
-
-OPENCL_ICD_COMMIT="bc9728edf8cace79cf33bf75560be88fc2432dc4"
-SRC_URI="https://github.com/KhronosGroup/OpenCL-ICD-Loader/archive/${OPENCL_ICD_COMMIT}.tar.gz -> OpenCL-ICD-Loader-${OPENCL_ICD_COMMIT}.tar.gz"
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/"
- inherit git-r3
-else
- SRC_URI+=" https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/ROCm-OpenCL-Runtime-roc-${PV}"
-fi
-
-DESCRIPTION="Radeon Open Compute OpenCL Compatible Runtime"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime"
-
-LICENSE="Apache-2.0 MIT"
-SLOT="0/$(ver_cut 1-2)"
-
-RDEPEND="dev-libs/rocr-runtime
- dev-libs/rocm-comgr
- dev-libs/rocm-device-libs
- dev-libs/rocm-opencl-driver"
-DEPEND="${RDEPEND}
- dev-lang/ocaml
- dev-ml/findlib"
-
-PATCHES=(
- "${FILESDIR}/${P}-unbundle-dependencies.patch"
-)
-
-src_prepare() {
- mkdir -p "${S}"/api/opencl/khronos/ || die
- mv "${WORKDIR}/OpenCL-ICD-Loader-${OPENCL_ICD_COMMIT}" "${S}"/api/opencl/khronos/icd || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/"
- -DClang_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/clang/"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
- )
- cmake-utils_src_configure
-}