summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-08-22 19:55:33 +0200
committerCraig Andrews <candrews@gentoo.org>2020-08-22 13:49:08 -0400
commitae21020147699ac175dcbdd89b271b5cb762c540 (patch)
treeac9f92fc9ab0a6f005fd943bc91d83a6a5a2012f /dev-libs/rocr-runtime/files
parentdev-python/oct2py: Remove old 3.6.0, 4.0.6 (diff)
downloadgentoo-ae21020147699ac175dcbdd89b271b5cb762c540.tar.gz
gentoo-ae21020147699ac175dcbdd89b271b5cb762c540.tar.bz2
gentoo-ae21020147699ac175dcbdd89b271b5cb762c540.zip
dev-libs/rocr-runtime: Version bump to 3.7.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Closes: https://github.com/gentoo/gentoo/pull/17213 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/files')
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-3.7.0-cmake-install-paths.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-3.7.0-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-3.7.0-cmake-install-paths.patch
new file mode 100644
index 000000000000..ccf397d8092a
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-3.7.0-cmake-install-paths.patch
@@ -0,0 +1,53 @@
+--- a/CMakeLists.txt 2020-08-22 18:24:27.991014917 +0200
++++ b/CMakeLists.txt 2020-08-22 18:48:03.209009518 +0200
+@@ -296,34 +296,36 @@
+ endif()
+
+ ## Create symlinks for legacy packaging and install
+-add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../include/hsa hsa_include_link )
+-if ( ${BUILD_SHARED_LIBS} )
+- add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
+- add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} )
+-endif()
++#add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../include/hsa hsa_include_link )
++#if ( ${BUILD_SHARED_LIBS} )
++# add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
++# add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} )
++#endif()
+
+ ## Set install information
+ # Installs binaries and exports the library usage data to ${HSAKMT_TARGET}Targets
+ # TODO: Fix me for flat directory layout. Should be ${CMAKE_INSTALL_LIBDIR}
+-install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets
+- ARCHIVE DESTINATION lib COMPONENT binary
+- LIBRARY DESTINATION lib COMPONENT binary )
++#install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets
++# ARCHIVE DESTINATION lib COMPONENT binary
++# LIBRARY DESTINATION lib COMPONENT binary )
++install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
+
+ # Install license
+ #install ( FILES ${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.md DESTINATION ${CMAKE_INSTALL_DOCDIR} COMPONENT binary )
+
+ # Install public headers
+ # TODO: Fix me for flat directory layout. Should be ${CMAKE_INSTALL_INCLUDEDIR}
+-install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION include/hsa COMPONENT dev )
++#install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION include/hsa COMPONENT dev )
++install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
+
+ # Legacy symlink.
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION hsa/include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa COMPONENT dirlink)
++#install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION hsa/include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa COMPONENT dirlink)
+
+ # Legacy symlinks.
+-if ( ${BUILD_SHARED_LIBS} )
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so COMPONENT binary)
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} COMPONENT binary)
+-endif ()
++#if ( ${BUILD_SHARED_LIBS} )
++# install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so COMPONENT binary)
++# install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} COMPONENT binary)
++#endif ()
+
+ ## Configure and install package config file
+ # Record our usage data for clients find_package calls.