summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-04-08 15:17:51 -0400
committerCraig Andrews <candrews@gentoo.org>2021-04-08 15:18:16 -0400
commit46cc53d53d30eee0e4a241efb9c640b5aefb4695 (patch)
tree9ce394f5e2c76c9a1db4be181a257c455015d925 /dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
parentdev-db/innotop: bump to v1.13.0 (diff)
downloadgentoo-46cc53d53d30eee0e4a241efb9c640b5aefb4695.tar.gz
gentoo-46cc53d53d30eee0e4a241efb9c640b5aefb4695.tar.bz2
gentoo-46cc53d53d30eee0e4a241efb9c640b5aefb4695.zip
dev-libs/rocr-runtime: add debug USE flag
Closes: https://bugs.gentoo.org/780480 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
index 75444f1b60de..caacf00b4bf8 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
@@ -23,6 +23,7 @@ PATCHES=(
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
+IUSE="debug"
COMMON_DEPEND="sys-process/numactl
dev-libs/elfutils:="
@@ -44,3 +45,8 @@ src_prepare() {
cmake_src_prepare
}
+
+src_configure() {
+ use debug || local mycmakeargs=(-DCMAKE_CXX_FLAGS='-DNDEBUG')
+ cmake_src_configure
+}