summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 20:47:05 -0400
committerSam James <sam@gentoo.org>2024-03-12 02:24:44 +0000
commitc4d27d80a6c8b0e9c0812018bdeb7d870fd16aa8 (patch)
tree4cbe9612b8f8b98bfea3861c725d1f2eb9b5e201 /dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
parentdev-libs/roct-thunk-interface: remove outdated seds (diff)
downloadgentoo-c4d27d80a6c8b0e9c0812018bdeb7d870fd16aa8.tar.gz
gentoo-c4d27d80a6c8b0e9c0812018bdeb7d870fd16aa8.tar.bz2
gentoo-c4d27d80a6c8b0e9c0812018bdeb7d870fd16aa8.zip
dev-libs/rocr-runtime: remove incorrect sed that doesn't apply
* SED: the following did not cause any changes * sed -i -e "s:1.7.0:${PV}:" CMakeLists.txt || die; * no-op: -e s:1.7.0:5.7.1: I don't actually understand the reasoning for attempting to modify it at all, since the cmake function that this is an argument to (before it changed to 1.8.0) explicitly takes the value, splits it on the periods and adds each component to a VERSION_MAJOR etc cmake variable. Then it also runs git, regardless of the input value, and tries to calculate VERSION_COMMIT_COUNT. So, there was nothing to fix as far as I can tell here? The only thing sed'ing this out would ever do AFAICT is change the soname of libraries from "1.7.0" to whatever the current ${PV} is... which is NOT how sonames work, and upstream had a good reason to NOT have this be ${PV}. It's quite irrelevant now since clearly the package worked just fine despite the sed not applying, thus it *cannot* be fixing anything, and also thus, there is clearly nothing to fix. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild b/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
index 4d026cf3ce50..6982173e2eb6 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,11 +44,6 @@ src_prepare() {
# Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
sed -e "s:-O2:--rocm-path=${EPREFIX}/usr/lib/ -O2:" -i image/blit_src/CMakeLists.txt || die
- # internal version depends on git being present and random weird magic, otherwise fallback to incoherent default value
- # fix default value to be more better
-
- sed -i -e "s:1.7.0:${PV}:" CMakeLists.txt || die
-
cmake_src_prepare
}