summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2021-06-28 21:45:49 +0200
committerCraig Andrews <candrews@gentoo.org>2021-06-28 16:04:57 -0400
commitf41a00ce9c69c16c6abbd22a23cd18a69d33c4ef (patch)
tree2cd4ca124618d5cc2cd8ebb334794129f213c895 /dev-libs/rocr-runtime
parentdev-libs/rocm-device-libs: Version bump to 4.2.0 (diff)
downloadgentoo-f41a00ce9c69c16c6abbd22a23cd18a69d33c4ef.tar.gz
gentoo-f41a00ce9c69c16c6abbd22a23cd18a69d33c4ef.tar.bz2
gentoo-f41a00ce9c69c16c6abbd22a23cd18a69d33c4ef.zip
dev-libs/rocr-runtime: Version bump to 4.2.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/Manifest1
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/Manifest b/dev-libs/rocr-runtime/Manifest
index 18bacae77eb8..418f9e35e908 100644
--- a/dev-libs/rocr-runtime/Manifest
+++ b/dev-libs/rocr-runtime/Manifest
@@ -3,3 +3,4 @@ DIST rocr-runtime-3.8.0.tar.gz 691209 BLAKE2B 0664b099a7ea4105e37cf42ee208c31dc5
DIST rocr-runtime-3.9.0.tar.gz 691645 BLAKE2B c90cdba93be510532a65ebfd69322972c61603b23932b95982d9a2bea742979b14acd83728a37ecacd7ec540268311bd313801acece89ec02a234dee66155dbe SHA512 e117536300ad05db27ccd92d2f9fadbdb9711fc724953ef65609c7af1ef369b8cf132c8b0f72d33e7ffd43acc3e59dc5525bacaa1507fd01fab79685f6b8d86e
DIST rocr-runtime-4.0.0.tar.gz 691835 BLAKE2B 328f7ea54767294036f435894d63354694447d964753de8b58b70ba5ae5f83561e5cda506890b43c80bdc480b1781d246ee77d5a0b08f74c5eb52d1ac5e8ddda SHA512 c95316cd8f221caee84f644e00b2b08d447b75ae4e5fe1871fa2ac6a879da57def497babfcabcaeb988d92421c165070e47d9fe846640b871249d66c82f82bea
DIST rocr-runtime-4.1.0.tar.gz 698452 BLAKE2B fb1ca1219d2c59db4d8bff414f40eaf6e7cec899a70ed930ce3dc6e2906a173db4823ac4c445fc57cc297a932f83b140747e35ee3d77fa0ed11cec97718fdc47 SHA512 d2162f431adf0b8f8ae5bbfe43ed389d4d94db5897fc8d1b4eb9b152a74f605fa2cf5d80175e6f9cda45e39803ededef6151aa9bdea99f38a16ca2dea29588d9
+DIST rocr-runtime-4.2.0.tar.gz 701445 BLAKE2B 901c256bae823861813a7afdbd3e9f80b6f86cf2c7002815e04c762cef241a9f32274093067c97578e05fdf5c4e699287b7835d00917cb4997302c455e5d593a SHA512 44a798efd0121c7107f3f5df868eb83d0ff9aad1e11c01105d5852bef159c019db6d2aeebe02e8e187dc45a2542d72f145fb5390b27abf64e0b427e192772d6c
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.2.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.2.0.ebuild
new file mode 100644
index 000000000000..75444f1b60de
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-rocm-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.1.0-cmake-install-paths.patch"
+)
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+COMMON_DEPEND="sys-process/numactl
+ dev-libs/elfutils:="
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}
+ >=dev-libs/rocm-device-libs-${PV}"
+BDEPEND="app-editors/vim-core"
+ # vim-core is needed for "xxd"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+
+ # ... otherwise system llvm/clang is used ...
+ sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS /usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
+
+ # Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
+ sed -e "s:/opt/rocm/amdgcn/bitcode:/usr/lib/amdgcn/bitcode:" -i image/blit_src/CMakeLists.txt || die
+
+ cmake_src_prepare
+}