summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2018-03-19 16:24:31 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 14:20:52 +0200
commit30e4e890be7d33d935694415e24bbd487b46dedf (patch)
tree230912ee841932af6153a0dec0dc9a45dfdf0c10 /dev-libs/sblim-sfcc/sblim-sfcc-2.2.8.ebuild
parentprofiles: Fix some p.mask dates (diff)
downloadgentoo-30e4e890be7d33d935694415e24bbd487b46dedf.tar.gz
gentoo-30e4e890be7d33d935694415e24bbd487b46dedf.tar.bz2
gentoo-30e4e890be7d33d935694415e24bbd487b46dedf.zip
dev-libs/sblim-sfcc: Update to 2.2.8
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7510
Diffstat (limited to 'dev-libs/sblim-sfcc/sblim-sfcc-2.2.8.ebuild')
-rw-r--r--dev-libs/sblim-sfcc/sblim-sfcc-2.2.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/sblim-sfcc/sblim-sfcc-2.2.8.ebuild b/dev-libs/sblim-sfcc/sblim-sfcc-2.2.8.ebuild
new file mode 100644
index 000000000000..b128ee38f4b3
--- /dev/null
+++ b/dev-libs/sblim-sfcc/sblim-sfcc-2.2.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Small Footprint CIM Client Library"
+HOMEPAGE="https://sourceforge.net/apps/mediawiki/sblim"
+SRC_URI="mirror://sourceforge/project/sblim/${PN}/${P}.tar.bz2"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ net-misc/curl[ssl]
+"
+RDEPEND="${DEPEND}"
+
+DOCS=()
+
+src_configure() {
+ local myconf=(
+ --enable-http-chunking
+ --disable-static
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}