summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-06-17 14:58:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-06-26 16:23:27 +0200
commit33fa4a390de86d91e9a264ad92095eb2a108c6f2 (patch)
treeb7b45bd5b97f44bdf5023fcee870d218af25e75c /dev-libs/sdformat/sdformat-6.2.0.ebuild
parentnet-vpn/freelan: bump to 2.2 (diff)
downloadgentoo-33fa4a390de86d91e9a264ad92095eb2a108c6f2.tar.gz
gentoo-33fa4a390de86d91e9a264ad92095eb2a108c6f2.tar.bz2
gentoo-33fa4a390de86d91e9a264ad92095eb2a108c6f2.zip
dev-libs/sdformat: bump to 6.2.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs/sdformat/sdformat-6.2.0.ebuild')
-rw-r--r--dev-libs/sdformat/sdformat-6.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/sdformat/sdformat-6.2.0.ebuild b/dev-libs/sdformat/sdformat-6.2.0.ebuild
new file mode 100644
index 000000000000..490e31f59dbe
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-6.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/sdformat/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# subslot = libsdformat major
+SLOT="0/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/urdfdom-1:=
+ dev-libs/tinyxml
+ dev-libs/boost:=
+ sci-libs/ignition-math:4=
+"
+DEPEND="${RDEPEND}
+ dev-lang/ruby:*
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ local mycmakeargs=(
+ "-DUSE_INTERNAL_URDF=OFF"
+ "-DUSE_EXTERNAL_TINYXML=ON"
+ )
+ cmake-utils_src_configure
+}