summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-10-11 15:15:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-10-11 18:28:28 +0200
commit966f87db49377754cdf71f8cb3fb5b5ccdf065e5 (patch)
tree91f63e8e41a6f9e94c8b76280baceeef6fec2e68 /dev-libs/sdformat
parentros-meta/ros_control: Bump to 0.15.1. (diff)
downloadgentoo-966f87db49377754cdf71f8cb3fb5b5ccdf065e5.tar.gz
gentoo-966f87db49377754cdf71f8cb3fb5b5ccdf065e5.tar.bz2
gentoo-966f87db49377754cdf71f8cb3fb5b5ccdf065e5.zip
dev-libs/sdformat: bump to 6.1.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs/sdformat')
-rw-r--r--dev-libs/sdformat/Manifest1
-rw-r--r--dev-libs/sdformat/sdformat-6.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/sdformat/Manifest b/dev-libs/sdformat/Manifest
index ad929aff9da4..19c8b11c3d1a 100644
--- a/dev-libs/sdformat/Manifest
+++ b/dev-libs/sdformat/Manifest
@@ -1,3 +1,4 @@
DIST sdformat-5.2.0.tar.bz2 445542 BLAKE2B 89daf9e03613bd88aceb1a2034cf0f9efe7b28ffb7aef8add4fc484a6e78d7189b4b6183fca83db4bb8017a4901d2fb3df7dc43e995bf2da8bb0fcde9510c6c9 SHA512 65df9f0d351ab894af41cc2081dc8ab179336092ceba17979720bed4d58f77e9648863501d83f073ea8478197e7e0a7d7a9f8efd3a54d22ee28d74765cebcee7
DIST sdformat-5.3.0.tar.bz2 447471 BLAKE2B 9b511782f5d2517778fc0c977d1deab00ee7789f50628546b5ca8c1f464cc3ca132b83e1054867ec1d6678bca664232e1d9a499ff095d4f9a623f5061fc340c1 SHA512 63106bc438decb00157eca5fd3f7f783197a1f17a76008bee5d18d5c146f199e67852ef74cbbc53918760a0cdf382628ea84d2b4618512738cd574de1fc719d8
DIST sdformat-6.0.0.tar.bz2 473765 BLAKE2B af3ed14323c2bed8ee5a22580dcb6d73a5e5c772f39ad7f806bf2cdb88d6f2c885585f36a666f2ec711dbd7ad6051ba69d79d2a9f0af7ad3b3681543b9feafe7 SHA512 2188de97cb1eb1117a694d54a0a42112bd7e5b5a4b00c04e049de73a10947904940565e36df93ca08ea5910e628983e234d07c57694c463e0794c48e20cedb21
+DIST sdformat-6.1.0.tar.bz2 465231 BLAKE2B 5b12c4974662245ecb01e342632e274b58512dd2c223dfbf8e1ef9bb2ba267f16bc130b62367b09a9cac9e2ccbd2829439d055f2fa062f34df9f4a6ceb1a571e SHA512 6c5a03e877cba3b734f1cb132582274249bd0cb3a8d463be9077519d8ad126bb15650947b5455b3cdd1abea727918b21369b40a12de4fc5d6806880fd8686b97
diff --git a/dev-libs/sdformat/sdformat-6.1.0.ebuild b/dev-libs/sdformat/sdformat-6.1.0.ebuild
new file mode 100644
index 000000000000..bc8209246277
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-6.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/sdformat/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# subslot = libsdformat major
+SLOT="0/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/urdfdom-1:=
+ dev-libs/tinyxml
+ dev-libs/boost:=
+ sci-libs/ignition-math:4=
+"
+DEPEND="${RDEPEND}
+ dev-lang/ruby:*
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ local mycmakeargs=(
+ "-DUSE_INTERNAL_URDF=OFF"
+ "-DUSE_EXTERNAL_TINYXML=ON"
+ )
+ cmake-utils_src_configure
+}