summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-05-29 08:38:43 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-05-29 08:46:26 +0200
commit4ca2e1ef6c665fca5b9a2d6701b352e45d0d4180 (patch)
tree6f095d27395071c7a8874f07d0a1b2f150b434ae /dev-libs/serd
parentmedia-sound/pulseaudio-daemon: Add local USE valgrind (diff)
downloadgentoo-4ca2e1ef6c665fca5b9a2d6701b352e45d0d4180.tar.gz
gentoo-4ca2e1ef6c665fca5b9a2d6701b352e45d0d4180.tar.bz2
gentoo-4ca2e1ef6c665fca5b9a2d6701b352e45d0d4180.zip
dev-libs/serd: bump to 0.30.12, added python3_11
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-libs/serd')
-rw-r--r--dev-libs/serd/Manifest1
-rw-r--r--dev-libs/serd/serd-0.30.12.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/serd/Manifest b/dev-libs/serd/Manifest
index 65108d8fe6d5..6b102ceac8d5 100644
--- a/dev-libs/serd/Manifest
+++ b/dev-libs/serd/Manifest
@@ -1 +1,2 @@
DIST serd-0.30.10.tar.bz2 586386 BLAKE2B 7f84b425a9eed36c5b59b22b8fd2cb9139a3de2bd1a47f92fd9888c433d931dcf83f13c2460d821c04f4244a79aa4330ba973017508ecb5f4564e78ae45b9b9a SHA512 ed7b49abfd3dc3a724b047f5f0cd07b811596330c96d91c0ce90540440f03260e05daee76c3ccccc3d4ca39afbbd4f3d07decbb601730e90c133a09c640c0006
+DIST serd-0.30.12.tar.bz2 594475 BLAKE2B acd065613494f05d1b2016c2097c1efbd1ebe3a5b901fac3a60d27140fee5c51ec17314df7ac2d3ad89d852dcb016dcf7255271f506f900445ce275335ed7d01 SHA512 c330648eb2c947a6d220f42d0af63fd2744da496301483e58be3cda387da166711d6acd5cee2df8cbb837ab450e1802b3f9a0a2973e5ad6d976b69b863aecb7f
diff --git a/dev-libs/serd/serd-0.30.12.ebuild b/dev-libs/serd/serd-0.30.12.ebuild
new file mode 100644
index 000000000000..8c6796d5801e
--- /dev/null
+++ b/dev-libs/serd/serd-0.30.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
+HOMEPAGE="http://drobilla.net/software/serd/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ dev-python/sphinx_lv2_theme
+)
+"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+"
+DOCS=( "AUTHORS" "NEWS" "README.md" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(multilib_native_usex doc --docs "") \
+ $(usex test --test "") \
+ $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+ ./waf test || die
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+ default
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ default
+}