summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/serd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/serd')
-rw-r--r--dev-libs/serd/Manifest2
-rw-r--r--dev-libs/serd/metadata.xml10
-rw-r--r--dev-libs/serd/serd-0.18.2.ebuild41
-rw-r--r--dev-libs/serd/serd-0.20.0.ebuild41
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/serd/Manifest b/dev-libs/serd/Manifest
new file mode 100644
index 000000000000..c638d6fe2804
--- /dev/null
+++ b/dev-libs/serd/Manifest
@@ -0,0 +1,2 @@
+DIST serd-0.18.2.tar.bz2 291053 SHA256 8e3d8402c33fa217572d3ee936919037420fb237fb8603a7b024ab482a94eac1 SHA512 2e775f50efbefa88d291999a26bf8e6602b5791affc9b9073451eb1406db654a63d2b91eb862ba7e714b5ce9ad51f7b7b259714476cd1532cf17fc072a923c3f WHIRLPOOL 85d8599a3c4f1c26d438b741b70f75b0c3b7265a973b93bafa45f59f3a669b664d979ff49f9894f36c76d1c1826818222a089051b7202a71b85f30d2cba80980
+DIST serd-0.20.0.tar.bz2 363807 SHA256 64515f4f5eb27ba2ba151027a72a77672f6ee8a2a3b58991ad5c045135feabbf SHA512 d313abb6423b0b1dd30b5c4f7ede45a5e51b3c8676b49215e106a75d73280e07c48b3895f2d88aeac2117eaf9c82cdb58bfc530895ad17a34d810c256868d1ef WHIRLPOOL 0cb4e6b9c870cc2bf5a34eb5c25a4a5fbcc90737ac646688338b9529baa774da29cd9f8659cdcc8f13e714949ea0ed840af28ed81a869465f8902b3e24cbeb27
diff --git a/dev-libs/serd/metadata.xml b/dev-libs/serd/metadata.xml
new file mode 100644
index 000000000000..1026eab86322
--- /dev/null
+++ b/dev-libs/serd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+<longdescription lang="en">
+ Serd is a lightweight C library for RDF syntax which supports reading and writing Turtle and NTriples.
+
+ Serd is not intended to be a swiss-army knife of RDF syntax, but rather is suited to resource limited or performance critical applications, or situations where a simple reader/writer with minimal dependencies is ideal (e.g. in LV2 hosts or plugins).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-libs/serd/serd-0.18.2.ebuild b/dev-libs/serd/serd-0.18.2.ebuild
new file mode 100644
index 000000000000..f8b9d1df228d
--- /dev/null
+++ b/dev-libs/serd/serd-0.18.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
+HOMEPAGE="http://drobilla.net/software/serd/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}
diff --git a/dev-libs/serd/serd-0.20.0.ebuild b/dev-libs/serd/serd-0.20.0.ebuild
new file mode 100644
index 000000000000..45fa87ddcb08
--- /dev/null
+++ b/dev-libs/serd/serd-0.20.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
+HOMEPAGE="http://drobilla.net/software/serd/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}