summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-19 19:48:08 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-30 13:44:32 +0200
commitb8f75793ffc80f43466bc645bd02e6525cd042a8 (patch)
tree20935f95bbc9b76457d359d49abb3353c69e48cd /dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
parentnet-misc/econnman: new package (diff)
downloadgentoo-b8f75793ffc80f43466bc645bd02e6525cd042a8.tar.gz
gentoo-b8f75793ffc80f43466bc645bd02e6525cd042a8.tar.bz2
gentoo-b8f75793ffc80f43466bc645bd02e6525cd042a8.zip
dev-libs/shhopt: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/666574 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9921
Diffstat (limited to 'dev-libs/shhopt/shhopt-1.1.7-r3.ebuild')
-rw-r--r--dev-libs/shhopt/shhopt-1.1.7-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild b/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
new file mode 100644
index 000000000000..83fb8b878ace
--- /dev/null
+++ b/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="library for parsing command line options"
+HOMEPAGE="http://shh.thathost.com/pub-unix/"
+SRC_URI="http://shh.thathost.com/pub-unix/files/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dolib.a libshhopt.a
+ ln -s libshhopt.so.${PV} libshhopt.so || die
+ ln -s libshhopt.so.${PV} libshhopt.so.${PV:0:1} || die
+ dolib.so libshhopt.so*
+ doheader shhopt.h
+ dodoc ChangeLog CREDITS README TODO
+}