summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-22 10:39:05 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-22 10:39:05 -0800
commitd03bbbe108ea2d44a44d41e104c015686d24094c (patch)
tree893403bcbcc62358251ff5f3c7eba12f627ca2db /dev-libs/simdjson/files
parentdev-util/chroot-wrapper-0.9.4: Version bump (diff)
downloadgentoo-d03bbbe108ea2d44a44d41e104c015686d24094c.tar.gz
gentoo-d03bbbe108ea2d44a44d41e104c015686d24094c.tar.bz2
gentoo-d03bbbe108ea2d44a44d41e104c015686d24094c.zip
dev-libs/simdjson-0.8.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/simdjson/files')
-rw-r--r--dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch b/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch
new file mode 100644
index 000000000000..6a76cf83ed98
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch
@@ -0,0 +1,40 @@
+diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
+index 2c41169f..2f5d4436 100644
+--- a/dependencies/CMakeLists.txt
++++ b/dependencies/CMakeLists.txt
+@@ -129,15 +129,3 @@ endfunction()
+ if(SIMDJSON_COMPETITION)
+ competition_scope_()
+ endif()
+-
+-cmake_dependent_option(SIMDJSON_CXXOPTS "Download cxxopts (necessary for tools)" ON
+- SIMDJSON_ALLOW_DOWNLOADS OFF)
+-
+-if(SIMDJSON_CXXOPTS)
+- set_off(CXXOPTS_BUILD_EXAMPLES)
+- set_off(CXXOPTS_BUILD_TESTS)
+- set_off(CXXOPTS_ENABLE_INSTALL)
+-
+- import_dependency(cxxopts jarro2783/cxxopts 794c975)
+- add_dependency(cxxopts)
+-endif()
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index f1a82be7..b1b7b1a0 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -1,10 +1,8 @@
+-if(TARGET cxxopts) # we only build the tools if cxxopts is available
+ message(STATUS "We have cxxopts as a dependency and we are buiding the tools (e.g., json2json).")
+- link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers cxxopts)
++ link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers)
+ add_executable(json2json json2json.cpp)
+ add_executable(jsonstats jsonstats.cpp)
+- add_executable(jsonpointer jsonpointer.cpp)
++ add_executable(simdjsonpointer jsonpointer.cpp)
+ add_executable(minify minify.cpp)
+-else()
+- message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
+-endif()
+\ No newline at end of file
++ install(TARGETS json2json jsonstats simdjsonpointer minify DESTINATION bin)
++