summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-10-28 09:43:45 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-10-28 09:44:16 -0700
commitbdfcda42bfda5fee4ae1826b449f87f05f32dadb (patch)
tree32a2d2d7d4e2cc2bdebbcb9f9277feed8cc0fbd0 /dev-libs/simdjson/simdjson-0.4.7.ebuild
parentdev-python/greenlet: Stabilize 0.4.17 arm, #751133 (diff)
downloadgentoo-bdfcda42bfda5fee4ae1826b449f87f05f32dadb.tar.gz
gentoo-bdfcda42bfda5fee4ae1826b449f87f05f32dadb.tar.bz2
gentoo-bdfcda42bfda5fee4ae1826b449f87f05f32dadb.zip
Revert "dev-libs/simdjson: Remove old"
This reverts commit 4a598d308f34e6fb8bf88c9f27574b4133115860. Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/simdjson/simdjson-0.4.7.ebuild')
-rw-r--r--dev-libs/simdjson/simdjson-0.4.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/simdjson/simdjson-0.4.7.ebuild b/dev-libs/simdjson/simdjson-0.4.7.ebuild
new file mode 100644
index 000000000000..77da37bac071
--- /dev/null
+++ b/dev-libs/simdjson/simdjson-0.4.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs cmake
+
+DESCRIPTION="SIMD accelerated C++ JSON library"
+HOMEPAGE="
+ https://simdjson.org/
+ https://github.com/simdjson/simdjson
+"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ sys-apps/file
+ sys-apps/findutils
+ sys-apps/grep
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(usex test '' '-DSIMDJSON_JUST_LIBRARY=ON')
+ )
+
+ cmake_src_configure
+}