summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-09-08 16:22:23 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-09-08 16:22:23 -0700
commit9e6955223160b1a7675406e106ea471ace8f404e (patch)
tree3914785f125ae179c5113f9f3350b4a4c00512a7 /dev-libs/simdjson
parentprofiles: [QA] mask =dev-libs/simdjson-1.0.0 (diff)
downloadgentoo-9e6955223160b1a7675406e106ea471ace8f404e.tar.gz
gentoo-9e6955223160b1a7675406e106ea471ace8f404e.tar.bz2
gentoo-9e6955223160b1a7675406e106ea471ace8f404e.zip
dev-libs/simdjson-1.0.0-r1: Bump, fix bug #812185
Closes: https://bugs.gentoo.org/812185 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/simdjson')
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch12
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch8
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch21
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-tests.patch17
-rw-r--r--dev-libs/simdjson/simdjson-1.0.0-r1.ebuild (renamed from dev-libs/simdjson/simdjson-1.0.0.ebuild)20
5 files changed, 58 insertions, 20 deletions
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch b/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch
index 316c4ba40061..f796677655d6 100644
--- a/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch
@@ -18,15 +18,3 @@ index 76651318..2cc06e9e 100644
- import_dependency(cxxopts jarro2783/cxxopts 794c975)
- add_dependency(cxxopts)
-endif()
-diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
-index f3eaa054..62c34cdd 100644
---- a/tools/CMakeLists.txt
-+++ b/tools/CMakeLists.txt
-@@ -1,6 +1,6 @@
- if(TARGET cxxopts) # we only build the tools if cxxopts is available
- message(STATUS "We have cxxopts as a dependency and we are building the tools (e.g., json2json).")
-- foreach(tool IN ITEMS json2json jsonstats jsonpointer minify)
-+ foreach(tool IN ITEMS json2json jsonstats simdjsonpointer minify)
- add_executable("${tool}" "${tool}.cpp")
- simdjson_apply_props("${tool}")
- target_link_libraries(
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch b/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch
index 2459604d9800..b3cd8558b2ff 100644
--- a/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch
@@ -1,14 +1,16 @@
diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
-index 76651318..91232ce0 100644
+index 76651318..da5029c0 100644
--- a/dependencies/CMakeLists.txt
+++ b/dependencies/CMakeLists.txt
-@@ -19,8 +19,7 @@ if(SIMDJSON_GOOGLE_BENCHMARKS)
+@@ -19,8 +19,9 @@ if(SIMDJSON_GOOGLE_BENCHMARKS)
endif()
# The bulk of our benchmarking and testing data has been moved simdjson/simdjson-data
-import_dependency(simdjson-data simdjson/simdjson-data a5b13babe65c1bba7186b41b43d4cbdc20a5c470)
-add_dependency(simdjson-data)
-+add_subdirectory(simdjson-data dependencies/simdjson-data)
++if(SIMDJSON_TESTS)
++ add_subdirectory(simdjson-data dependencies/simdjson-data)
++endif()
# This prevents variables declared with set() from unnecessarily escaping and
# should not be called more than once
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch b/dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch
new file mode 100644
index 000000000000..10d332315608
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch
@@ -0,0 +1,21 @@
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index f3eaa054..4eaff3d1 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -1,12 +1,13 @@
+-if(TARGET cxxopts) # we only build the tools if cxxopts is available
++if(SIMDJSON_TOOLS)
+ message(STATUS "We have cxxopts as a dependency and we are building the tools (e.g., json2json).")
+- foreach(tool IN ITEMS json2json jsonstats jsonpointer minify)
++ foreach(tool IN ITEMS json2json jsonstats simdjsonpointer minify)
+ add_executable("${tool}" "${tool}.cpp")
+ simdjson_apply_props("${tool}")
+ target_link_libraries(
+ "${tool}" PRIVATE
+- simdjson simdjson-internal-flags simdjson-windows-headers cxxopts
++ simdjson simdjson-internal-flags simdjson-windows-headers
+ )
++ install(TARGETS "${tool}")
+ endforeach()
+ else()
+ message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-tests.patch b/dev-libs/simdjson/files/simdjson-1.0.0-tests.patch
new file mode 100644
index 000000000000..cccbd4494667
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-tests.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 235222a8..8532183a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -221,9 +221,10 @@ add_subdirectory(singleheader)
+ #
+ # Compile tools / tests / benchmarks
+ #
+-add_subdirectory(tests)
++if (SIMDJSON_TESTS)
++ add_subdirectory(tests)
++endif()
+ add_subdirectory(examples)
+-add_subdirectory(benchmark)
+ add_subdirectory(fuzz)
+
+ #
diff --git a/dev-libs/simdjson/simdjson-1.0.0.ebuild b/dev-libs/simdjson/simdjson-1.0.0-r1.ebuild
index c68fa749db0b..4ad5cdab99d5 100644
--- a/dev-libs/simdjson/simdjson-1.0.0.ebuild
+++ b/dev-libs/simdjson/simdjson-1.0.0-r1.ebuild
@@ -37,6 +37,8 @@ PATCHES=(
"${FILESDIR}/simdjson-1.0.0-dont-bundle-cxxopts.patch"
"${FILESDIR}/simdjson-0.9.0-tests.patch"
"${FILESDIR}/simdjson-1.0.0-dont-fetch-data-tarball.patch"
+ "${FILESDIR}/simdjson-1.0.0-install-tools.patch"
+ "${FILESDIR}/simdjson-1.0.0-tests.patch"
)
DOCS=(
@@ -48,27 +50,35 @@ DOCS=(
)
src_prepare() {
- mv "${WORKDIR}/${PN}-data-${DATA_HASH}" "${S}/dependencies/${PN}-data" || die
+ if use test; then
+ mv "${WORKDIR}/${PN}-data-${DATA_HASH}" "${S}/dependencies/${PN}-data" || die
+ fi
+
sed -e 's:-Werror ::' -i cmake/developer-options.cmake || die
sed -e "s:^c++ :$(tc-getCXX) :" -i singleheader/README.md || die
+ mv tools/{,simd}jsonpointer.cpp || die
cmake_src_prepare
}
src_configure() {
local -a mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
- -DSIMDJSON_ALLOW_DOWNLOADS=OFF
+ )
+ use test && mycmakeargs+=(
+ -DSIMDJSON_TESTS=ON
)
if use tools; then
mycmakeargs+=(
- -DSIMDJSON_JUST_LIBRARY=OFF
+ -DSIMDJSON_DEVELOPER_MODE=ON
+ -DSIMDJSON_ALLOW_DOWNLOADS=OFF
-DSIMDJSON_GOOGLE_BENCHMARKS=OFF
-DSIMDJSON_COMPETITION=OFF
+ -DSIMDJSON_TOOLS=ON
)
- else
+ elif ! use test; then
mycmakeargs+=(
- -DSIMDJSON_DEVELOPER_MODE=ON
+ -DSIMDJSON_DEVELOPER_MODE=OFF
)
fi