summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-02-01 15:08:34 +0000
committerMichael Palimaka <kensington@gentoo.org>2018-02-02 22:40:22 +1100
commit64f5fc144c50effd9566ed1869d5d6150cd54999 (patch)
tree74d49635bfba42ba8e036480faa085dd1b4955ba /dev-libs/sink/sink-0.5.0.ebuild
parentdev-ruby/bit-struct: fix rubygems in metadata (diff)
downloadgentoo-64f5fc144c50effd9566ed1869d5d6150cd54999.tar.gz
gentoo-64f5fc144c50effd9566ed1869d5d6150cd54999.tar.bz2
gentoo-64f5fc144c50effd9566ed1869d5d6150cd54999.zip
dev-libs/sink: add 0.5.0 release
Diffstat (limited to 'dev-libs/sink/sink-0.5.0.ebuild')
-rw-r--r--dev-libs/sink/sink-0.5.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/sink/sink-0.5.0.ebuild b/dev-libs/sink/sink-0.5.0.ebuild
new file mode 100644
index 000000000000..06692c9740c7
--- /dev/null
+++ b/dev-libs/sink/sink-0.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true" # build breaks otherwise. tests not isolated.
+inherit kde5
+
+DESCRIPTION="A data access layer handling synchronization, caching and indexing"
+SRC_URI="https://github.com/KDE/sink/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# qtgui is bogus but is required because something else in the deptree
+# uses it as a public dependency but doesn't search for it properly
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ dev-db/lmdb:=
+ dev-libs/flatbuffers
+ dev-libs/kasync
+ net-libs/kdav2
+ net-libs/kimap2
+ net-misc/curl
+ sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}"
+
+# fails to build
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ # FIXME: sink is useless without its 'examples'. Workaround our eclass
+ sed -i -e "/add_subdirectory(examples)/ s/#DONOTCOMPILE //" \
+ CMakeLists.txt || die "Failed to fix CMakeLists.txt"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libgit2=ON
+ )
+ kde5_src_configure
+}