summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-16 19:17:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-16 19:19:32 +0100
commitb3e3cccb2706c57d2b32cf938916b6ac64130130 (patch)
treef530dba842b89ed62a2d39094c5df7558065cf96 /dev-libs/sink
parentmedia-libs/imlib2: stable 1.6.1 for hppa/sparc, bug #705460 (diff)
downloadgentoo-b3e3cccb2706c57d2b32cf938916b6ac64130130.tar.gz
gentoo-b3e3cccb2706c57d2b32cf938916b6ac64130130.tar.bz2
gentoo-b3e3cccb2706c57d2b32cf938916b6ac64130130.zip
dev-libs/sink: Disable broken tests everywhere
Incidentally also changes install image. What a mess. Closes: https://bugs.gentoo.org/704280 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/sink')
-rw-r--r--dev-libs/sink/sink-0.8.0-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/sink/sink-0.8.0-r2.ebuild b/dev-libs/sink/sink-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..02e229bc471f
--- /dev/null
+++ b/dev-libs/sink/sink-0.8.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Data access layer handling synchronization, caching and indexing"
+HOMEPAGE="https://kube-project.com"
+SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+
+# qtgui is bogus but is required because something else in the deptree
+# uses it as a public dependency but doesn't search for it properly
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
+RDEPEND="
+ dev-db/lmdb:=
+ dev-libs/flatbuffers
+ >=dev-libs/kasync-0.3:5
+ >=dev-libs/xapian-1.4.4:0=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ kde-apps/kmime:5
+ kde-frameworks/kcalendarcore:5
+ kde-frameworks/kcontacts:5
+ kde-frameworks/kcoreaddons:5
+ >=net-libs/kdav2-0.3:5
+ >=net-libs/kimap2-0.3:5
+ net-misc/curl
+ sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+"
+
+# fails to build
+RESTRICT+=" test"
+
+src_prepare() {
+ cmake_src_prepare
+ # tests are sprinkled all over the place, and examples are needed...
+ # disabling tests disables installing 'hawd'... what a mess
+ sed -e "/add_subdirectory(tests)/ s/^/#DONT/" \
+ -i CMakeLists.txt examples/imapresource/CMakeLists.txt \
+ examples/mail{transport,dir}resource/CMakeLists.txt \
+ examples/ca{l,rd}davresource/CMakeLists.txt \
+ || die "Failed to disable tests everywhere"
+}