summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-05-17 08:36:52 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-05-17 08:36:52 +0200
commitc59fc76ed4aba00bed30c69a102daaaf4867d1e8 (patch)
tree92b55f0a5f5d2414c0d5dd9a59bd403a750c2112 /dev-libs/sleef/sleef-3.5.1.ebuild
parentmedia-libs/babl: fix build w/ meson-0.62 for 0.1.90 too (diff)
downloadgentoo-c59fc76ed4aba00bed30c69a102daaaf4867d1e8.tar.gz
gentoo-c59fc76ed4aba00bed30c69a102daaaf4867d1e8.tar.bz2
gentoo-c59fc76ed4aba00bed30c69a102daaaf4867d1e8.zip
dev-libs/sleef: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-libs/sleef/sleef-3.5.1.ebuild')
-rw-r--r--dev-libs/sleef/sleef-3.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/sleef/sleef-3.5.1.ebuild b/dev-libs/sleef/sleef-3.5.1.ebuild
new file mode 100644
index 000000000000..7d994a46c2f5
--- /dev/null
+++ b/dev-libs/sleef/sleef-3.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implements vectorized versions of C standard math functions"
+HOMEPAGE="https://sleef.org/"
+SRC_URI="https://github.com/shibatch/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_FFTW=ON
+ -DBUILD_TESTS=$(usex test ON OFF)
+ )
+
+ cmake_src_configure
+}