summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-11 00:27:10 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-11 00:27:35 +0200
commit64d9e19a8899c2a9d8e748c6fa3746bb16e025f5 (patch)
treead9cb31ea1bf9d3072138f4d0bd1a3ac4de9ee63 /dev-libs/softhsm/softhsm-2.2.0-r3.ebuild
parentnet-irc/irker: re-add ~arm keyword (bug 592888). (diff)
downloadgentoo-64d9e19a8899c2a9d8e748c6fa3746bb16e025f5.tar.gz
gentoo-64d9e19a8899c2a9d8e748c6fa3746bb16e025f5.tar.bz2
gentoo-64d9e19a8899c2a9d8e748c6fa3746bb16e025f5.zip
dev-libs/softhsm: fix local state directory
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-libs/softhsm/softhsm-2.2.0-r3.ebuild')
-rw-r--r--dev-libs/softhsm/softhsm-2.2.0-r3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/softhsm/softhsm-2.2.0-r3.ebuild b/dev-libs/softhsm/softhsm-2.2.0-r3.ebuild
new file mode 100644
index 000000000000..c0e2a04a0ee7
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-2.2.0-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="http://www.opendnssec.org/"
+SRC_URI="http://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="bindist libressl +migration-tool test"
+SLOT="2"
+LICENSE="BSD"
+
+RDEPEND="
+ sys-devel/gcc:=[cxx]
+ dev-db/sqlite:3
+ !libressl? ( dev-libs/openssl:=[bindist=] )
+ libressl? ( dev-libs/libressl )
+ !=dev-libs/softhsm-2.0.0:0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-libressl.patch"
+)
+DOCS=( NEWS README.md )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --localstatedir="${EROOT}var" \
+ --with-crypto-backend=openssl \
+ --disable-p11-kit \
+ $(use_enable !bindist ecc) \
+ $(use_enable !libressl gost) \
+ $(use_with migration-tool migrate)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}