summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-13 10:47:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-13 10:47:26 +0200
commit0eb5f1801408da30cce60dcd8920470b51d15917 (patch)
tree45c02e372ced5df2622371b41584a9629319f3b0 /dev-libs/sord/sord-0.14.0.ebuild
parentmedia-sound/qtractor: Bump to 0.7.1 (diff)
downloadgentoo-0eb5f1801408da30cce60dcd8920470b51d15917.tar.gz
gentoo-0eb5f1801408da30cce60dcd8920470b51d15917.tar.bz2
gentoo-0eb5f1801408da30cce60dcd8920470b51d15917.zip
dev-libs/sord: Bump to 0.14.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-libs/sord/sord-0.14.0.ebuild')
-rw-r--r--dev-libs/sord/sord-0.14.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/sord/sord-0.14.0.ebuild b/dev-libs/sord/sord-0.14.0.ebuild
new file mode 100644
index 000000000000..d831988d5535
--- /dev/null
+++ b/dev-libs/sord/sord-0.14.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/serd-0.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}