summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-27 19:55:05 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-27 19:55:36 +0200
commit7b230dffe237b6e7868b26b6ba648df35d97c4b6 (patch)
tree0eac58f2520c518022f56b304c076dfc42493d2c /dev-libs/sord
parentprofiles: ppc64: Drop obsolete x11-libs/vte:0[python] p.use.stable.mask (diff)
downloadgentoo-7b230dffe237b6e7868b26b6ba648df35d97c4b6.tar.gz
gentoo-7b230dffe237b6e7868b26b6ba648df35d97c4b6.tar.bz2
gentoo-7b230dffe237b6e7868b26b6ba648df35d97c4b6.zip
dev-libs/sord: bump to 0.16.6 + updated live
Bug: https://bugs.gentoo.org/723150 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-libs/sord')
-rw-r--r--dev-libs/sord/Manifest1
-rw-r--r--dev-libs/sord/files/sord-0.16.6-x86_32.patch44
-rw-r--r--dev-libs/sord/sord-0.16.6.ebuild61
-rw-r--r--dev-libs/sord/sord-9999.ebuild6
4 files changed, 111 insertions, 1 deletions
diff --git a/dev-libs/sord/Manifest b/dev-libs/sord/Manifest
index 5044bb236a4a..27fbf386c7c3 100644
--- a/dev-libs/sord/Manifest
+++ b/dev-libs/sord/Manifest
@@ -1,2 +1,3 @@
DIST drobilla-autowaf-6c6c1d29bfe4c28dd26b5cde7ea4a1a148ee700d.tar.gz 384589 BLAKE2B d643df2e133c2b70e00d85562d1c30f8a01190b4c1e1a512b732d016db3ae77ff543d4acafc00309edb173e7bbaaf17b0c2844bef2ffe786c02a51930f03f29a SHA512 50b2d063866630c7c566af9da07c9ac0da2cf86e70f76ad6af57973ae0b346d4687c0b4263cefa90f0c0ba9e853a60583457c9f8b1313db3f4298ca2f0cfc4d3
+DIST sord-0.16.6.tar.bz2 520690 BLAKE2B 7ec248a78e0d9e525d640363414ddd32acc3e32817e2ab86e791fd9232a46658538c9a4db936a5daa7eeb5ef9f7bf13e1aa1429ab6d9fc769e1391a014da919f SHA512 1d3c2bf47ff7e4b533e4e737e2ece8e29bace78bb00c41a252ad5c583abdcba3baa05b189cb8651c212861a2eea3c690354c99d684fd0f343b40e74c94572f98
DIST sord-81e138633076c2d7ef7e1691845757208d02f478.tar.gz 293332 BLAKE2B 794aed020b14f0cd4bae851de12f24fe54c87202b69c3f21cc26a86f0da092b05ea2244279be16ab3231431a8a5fb0cbab7236c2e761715e9a1759bb5b3ab54b SHA512 ba0dd8a8434a04be3548b959789b5b81491cd2f91f6125d3620fa17d4d38ae18015db7cd72af71900a0a17331c6b5400756719a25e09e596590ff943798a5991
diff --git a/dev-libs/sord/files/sord-0.16.6-x86_32.patch b/dev-libs/sord/files/sord-0.16.6-x86_32.patch
new file mode 100644
index 000000000000..3effc4d44dc3
--- /dev/null
+++ b/dev-libs/sord/files/sord-0.16.6-x86_32.patch
@@ -0,0 +1,44 @@
+diff --git a/src/zix/digest.c b/src/zix/digest.c
+index 889cfde..00b9fcf 100644
+--- a/src/zix/digest.c
++++ b/src/zix/digest.c
+@@ -38,10 +38,12 @@ zix_digest_add(uint32_t hash, const void* const buf, const size_t len)
+ {
+ const uint8_t* str = (const uint8_t*)buf;
+
++#ifdef __x86_64__
+ for (size_t i = 0; i < (len / sizeof(uint64_t)); ++i) {
+ hash = (uint32_t)_mm_crc32_u64(hash, *(const uint64_t*)str);
+ str += sizeof(uint64_t);
+ }
++#endif
+ if (len & sizeof(uint32_t)) {
+ hash = _mm_crc32_u32(hash, *(const uint32_t*)str);
+ str += sizeof(uint32_t);
+@@ -57,6 +59,7 @@ zix_digest_add(uint32_t hash, const void* const buf, const size_t len)
+ return hash;
+ }
+
++#ifdef __x86_64__
+ ZIX_API uint32_t
+ zix_digest_add_64(uint32_t hash, const void* const buf, const size_t len)
+ {
+@@ -72,12 +75,17 @@ zix_digest_add_64(uint32_t hash, const void* const buf, const size_t len)
+
+ return hash;
+ }
++#endif
+
+ ZIX_API uint32_t
+ zix_digest_add_ptr(const uint32_t hash, const void* const ptr)
+ {
+ #if UINTPTR_MAX == UINT64_MAX
+- return (uint32_t)_mm_crc32_u64(hash, (uintptr_t)ptr);
++ #ifdef __x86_64__
++ return (uint32_t)_mm_crc32_u64(hash, (uintptr_t)ptr);
++ #else
++ return (uint32_t)_mm_crc32_u32(hash, (uintptr_t)ptr);
++ #endif
+ #else
+ return _mm_crc32_u32(hash, (uintptr_t)ptr);
+ #endif
diff --git a/dev-libs/sord/sord-0.16.6.ebuild b/dev-libs/sord/sord-0.16.6.ebuild
new file mode 100644
index 000000000000..bd3d4f728ec6
--- /dev/null
+++ b/dev-libs/sord/sord-0.16.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/serd
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README.md" )
+
+PATCHES=(
+ "${FILESDIR}/${P}-x86_32.patch"
+)
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(multilib_native_usex doc --docs "") \
+ $(usex test --test "") \
+ $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+ ./waf test || die
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+ default
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ default
+}
diff --git a/dev-libs/sord/sord-9999.ebuild b/dev-libs/sord/sord-9999.ebuild
index e1388ab2877c..acfd96a2744a 100644
--- a/dev-libs/sord/sord-9999.ebuild
+++ b/dev-libs/sord/sord-9999.ebuild
@@ -19,7 +19,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/libpcre
- >=dev-libs/serd-0.30.0
+ dev-libs/serd
"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
DOCS=( "AUTHORS" "NEWS" "README.md" )
+PATCHES=(
+ "${FILESDIR}/${P}-0.16.6-x86_32.patch"
+)
+
src_prepare() {
sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
default