summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-01-20 22:08:54 +0100
committerCraig Andrews <candrews@gentoo.org>2020-01-20 21:12:34 -0500
commitcb4209494b05520fa84511c0ec3df825085af73e (patch)
tree98f46ce262b3a5de1678ae2cffe16699351a15c8 /dev-libs/spdlog/spdlog-9999.ebuild
parentsci-libs/m4ri: various upstreamed patches (diff)
downloadgentoo-cb4209494b05520fa84511c0ec3df825085af73e.tar.gz
gentoo-cb4209494b05520fa84511c0ec3df825085af73e.tar.bz2
gentoo-cb4209494b05520fa84511c0ec3df825085af73e.zip
dev-libs/spdlog: bump to 1.5.0
Closes: https://bugs.gentoo.org/696710 Closes: https://bugs.gentoo.org/699346 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14113 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog/spdlog-9999.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/dev-libs/spdlog/spdlog-9999.ebuild b/dev-libs/spdlog/spdlog-9999.ebuild
index f0b80109ac4a..060e167a8afd 100644
--- a/dev-libs/spdlog/spdlog-9999.ebuild
+++ b/dev-libs/spdlog/spdlog-9999.ebuild
@@ -10,9 +10,9 @@ HOMEPAGE="https://github.com/gabime/spdlog"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/spdlog"
+ EGIT_REPO_URI="https://github.com/gabime/${PN}"
else
- SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -21,19 +21,25 @@ SLOT="0/1"
IUSE="test"
RESTRICT="!test? ( test )"
+BDEPEND="
+ virtual/pkgconfig
+"
DEPEND="
- >=dev-libs/libfmt-5.0.0
+ >=dev-libs/libfmt-5.3.0:=
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-9999-unbundle-fmt.patch" )
+src_prepare() {
+ cmake_src_prepare
+ rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
+}
src_configure() {
- rm -r include/spdlog/fmt/bundled || die
-
local mycmakeargs=(
- -DSPDLOG_BUILD_EXAMPLE=no
-DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_EXAMPLE=no
+ -DSPDLOG_FMT_EXTERNAL=yes
+ -DSPDLOG_BUILD_SHARED=no
-DSPDLOG_BUILD_TESTS=$(usex test)
)