summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-02-26 01:32:47 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2016-02-26 01:33:12 +0100
commite13920ddc012357e14189364dee85e8e8c7a264d (patch)
tree6c368727bbf95aef44702ca9ef051d389c4067f6 /dev-libs/squareball/squareball-9999.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.4.3. BFQ Patchset v7r11 for 4.4.3 (diff)
downloadgentoo-e13920ddc012357e14189364dee85e8e8c7a264d.tar.gz
gentoo-e13920ddc012357e14189364dee85e8e8c7a264d.tar.bz2
gentoo-e13920ddc012357e14189364dee85e8e8c7a264d.zip
dev-libs/squareball: new package
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/squareball/squareball-9999.ebuild')
-rw-r--r--dev-libs/squareball/squareball-9999.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/squareball/squareball-9999.ebuild b/dev-libs/squareball/squareball-9999.ebuild
new file mode 100644
index 000000000000..e1e1c16524c3
--- /dev/null
+++ b/dev-libs/squareball/squareball-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="
+ git://github.com/rafaelmartins/squareball.git
+ https://github.com/rafaelmartins/squareball.git"
+ inherit git-r3 autotools
+fi
+
+inherit eutils
+
+DESCRIPTION="A general-purpose library for C99"
+HOMEPAGE="https://github.com/rafaelmartins/squareball"
+
+SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test static-libs"
+
+RDEPEND=""
+
+# pkg-config is used only to find cmocka libraries
+DEPEND="${DEPEND}
+ test? (
+ virtual/pkgconfig
+ dev-util/cmocka )
+ doc? (
+ app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ $(use_enable test tests) \
+ $(use_enable static-libs static) \
+ --disable-valgrind
+}
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/build/html/*
+}