summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/stfl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/stfl/files')
-rw-r--r--dev-libs/stfl/files/stfl-0.21-python.patch39
-rw-r--r--dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch14
-rw-r--r--dev-libs/stfl/files/stfl-0.22-soname-symlink.patch10
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/stfl/files/stfl-0.21-python.patch b/dev-libs/stfl/files/stfl-0.21-python.patch
new file mode 100644
index 000000000000..dbec12b7a6a4
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.21-python.patch
@@ -0,0 +1,39 @@
+diff -ur stfl-0.21.orig/Makefile stfl-0.21/Makefile
+--- stfl-0.21.orig/Makefile 2009-06-19 10:30:52.000000000 -0700
++++ stfl-0.21/Makefile 2009-12-23 15:12:34.986593069 -0800
+@@ -46,7 +46,7 @@
+ rm -f widgets/*.o spl/mod_stfl.so spl/example.db
+ cd perl5 && perl Makefile.PL && make clean && rm -f Makefile.old
+ rm -f perl5/stfl_wrap.c perl5/stfl.pm perl5/build_ok
+- rm -f python/stfl.py python/stfl.pyc python/_stfl.so
++ rm -f python/stfl.py python/_stfl.so
+ rm -f python/stfl_wrap.c python/stfl_wrap.o
+ rm -f ruby/Makefile ruby/stfl_wrap.c ruby/stfl_wrap.o
+ rm -f ruby/stfl.so ruby/build_ok Makefile.deps_new
+diff -ur stfl-0.21.orig/python/Makefile.snippet stfl-0.21/python/Makefile.snippet
+--- stfl-0.21.orig/python/Makefile.snippet 2009-06-18 01:27:16.000000000 -0700
++++ stfl-0.21/python/Makefile.snippet 2009-12-23 15:14:54.237606055 -0800
+@@ -21,20 +21,17 @@
+ PYTHON_VERSION = $(shell python -V 2>&1 | cut -f2 -d' ' | cut -f1-2 -d'.')
+ PYTHON_SITEARCH = $(shell python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
+
+-all: python/_stfl.so python/stfl.py python/stfl.pyc
++all: python/_stfl.so python/stfl.py
+
+ install: install_python
+
+-python/_stfl.so python/stfl.py python/stfl.pyc: libstfl.a stfl.h python/stfl.i swig/*.i
++python/_stfl.so python/stfl.py: libstfl.a stfl.h python/stfl.i swig/*.i
+ cd python && swig -python -threads stfl.i
+ gcc -shared -pthread -fPIC python/stfl_wrap.c -I/usr/include/python$(PYTHON_VERSION) \
+ -I. libstfl.a -lncursesw -o python/_stfl.so
+- cd python && python -c 'import stfl'
+
+-install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+- mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/
++install_python: python/_stfl.so python/stfl.py
+ mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+ cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+- cp python/stfl.pyc $(DESTDIR)$(PYTHON_SITEARCH)/
+ cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/
+
diff --git a/dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch b/dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch
new file mode 100644
index 000000000000..90698ec88dd7
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch
@@ -0,0 +1,14 @@
+--- stfl-0.22/ruby/Makefile.snippet.orig
++++ stfl-0.22/ruby/Makefile.snippet
+@@ -23,9 +23,9 @@
+
+ install: install_ruby
+
+-ruby/build_ok: libstfl.a stfl.h ruby/stfl.i swig/*.i
++ruby/build_ok: libstfl.so.$(VERSION) stfl.h ruby/stfl.i swig/*.i
+ cd ruby && swig -ruby stfl.i && ruby extconf.rb
+- $(MAKE) -C ruby clean && $(MAKE) -C ruby LIBS+="../libstfl.a -lncursesw" CFLAGS+="-pthread -I.." DLDFLAGS+="-pthread" DESTDIR=$(DESTDIR) prefix=$(prefix) sitedir=$(prefix)/$(libdir)/ruby
++ $(MAKE) -C ruby clean && $(MAKE) -C ruby LIBS+="../libstfl.so.$(VERSION) -lncursesw" CFLAGS+="-pthread -I.." DLDFLAGS+="-pthread" DESTDIR=$(DESTDIR) prefix=$(prefix) sitedir=$(prefix)/$(libdir)/ruby
+ touch ruby/build_ok
+
+ install_ruby: ruby/build_ok
diff --git a/dev-libs/stfl/files/stfl-0.22-soname-symlink.patch b/dev-libs/stfl/files/stfl-0.22-soname-symlink.patch
new file mode 100644
index 000000000000..bfe0595edc76
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.22-soname-symlink.patch
@@ -0,0 +1,10 @@
+--- stfl-0.22/Makefile.orig
++++ stfl-0.22/Makefile
+@@ -65,6 +65,7 @@
+ install -m 644 stfl.pc $(DESTDIR)$(prefix)/$(libdir)/pkgconfig/
+ install -m 644 libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)
+ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libstfl.so
++ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/$(SONAME)
+
+ stfl.pc: stfl.pc.in
+ sed 's,@VERSION@,$(VERSION),g' < $< | sed 's,@PREFIX@,$(prefix),g' > $@