summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-09-16 04:46:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-09-16 04:46:46 -0400
commitef73cef04489178f2388810c49dc16cc34ba00c0 (patch)
treeb42150aacbf03187a4ed2a20d9ece39cc6aaf888 /dev-libs/tinyxml2/tinyxml2-3.0.0.ebuild
parentnet-misc/curl: amd64 stable wrt bug #593716 (diff)
downloadgentoo-ef73cef04489178f2388810c49dc16cc34ba00c0.tar.gz
gentoo-ef73cef04489178f2388810c49dc16cc34ba00c0.tar.bz2
gentoo-ef73cef04489178f2388810c49dc16cc34ba00c0.zip
dev-libs/tinyxml2: version bump to 3.0.0, required for encfs-1.9
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-3.0.0.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-3.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-3.0.0.ebuild b/dev-libs/tinyxml2/tinyxml2-3.0.0.ebuild
new file mode 100644
index 000000000000..f8c5596d38bf
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TEST=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+ ./xmltest || die "Tests failed"
+}