summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-29 11:49:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-29 22:28:01 +0200
commit51fb67d3159b08e74a8e03c19bccd68808bd318e (patch)
tree6ff0e5fa06d82913a5eb13babeac26372725c708 /dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
parentmedia-video/libva-utils: bump to 1.8.3 (diff)
downloadgentoo-51fb67d3159b08e74a8e03c19bccd68808bd318e.tar.gz
gentoo-51fb67d3159b08e74a8e03c19bccd68808bd318e.tar.bz2
gentoo-51fb67d3159b08e74a8e03c19bccd68808bd318e.zip
dev-libs/tinyxml2: bump to 5.0.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild b/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
new file mode 100644
index 000000000000..73b4c08b8e37
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-5.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}