summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-05-27 15:12:54 -0600
committerTim Harder <radhermit@gentoo.org>2020-05-27 15:19:10 -0600
commita67742286190ae8e50a25d2c4f6086131a474e67 (patch)
tree7c8bc34e2a6e20ea589840998243da106bfb3da0 /dev-libs/tinyxml2/tinyxml2-8.0.0.ebuild
parentdev-python/readme_renderer: Bump to 26.0 (diff)
downloadgentoo-a67742286190ae8e50a25d2c4f6086131a474e67.tar.gz
gentoo-a67742286190ae8e50a25d2c4f6086131a474e67.tar.bz2
gentoo-a67742286190ae8e50a25d2c4f6086131a474e67.zip
dev-libs/tinyxml2: version bump to 8.0.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-8.0.0.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-8.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-8.0.0.ebuild b/dev-libs/tinyxml2/tinyxml2-8.0.0.ebuild
new file mode 100644
index 000000000000..7dd8bbfaa182
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-8.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=( -DBUILD_TESTING=$(usex test) )
+ cmake_src_configure
+}